View Full Version : [ubuntu] Desktop fails to load past loggin

tenchi muro
July 14th, 2010, 09:57 PM
Hi, I'm not entirely sure if this is where this goes, but problems occurred after messing around with desktop interface areas

Basically after logging in my screen turns black and then seems to fail out back to the log in screen. No error message, nothing. log in -> black screen -> log in

Ive tried to boot in fail safe gnome with exact same result.

Problems started after these two actions

1) was trying to get compiz to handle the desktop, so I disabled "show desktop" through Nautilus ( I re-enabled before logging off however)

2) was stupid and tired and accidentally uninstalled libglib2.0-0, libglib2.0-data, and several other packages through the software center interface. Ive re installed these through root access but I must be missing some files because it still fails to start

Because im not entirely sure what is causing the problem ( failure to render, or missing crucial packages) im not sure how I should go about trying to repair. Is there any to restore factory settings and programs without blitzing out current drivers and apps ?

tenchi muro
July 14th, 2010, 11:43 PM
OK restored system. somehow Ubuntu-desktop, and Nautilus were both uninstalled .... not even sure how that happened - -

things seem to be running ok, but im not sure if what I did was a solid work around crossing my fingers and hopes it holds up