PDA

View Full Version : [ubuntu] run from live cd/install hangs, hardware issue?



gobbledigook
July 14th, 2010, 11:09 AM
hi there!

I'm having trouble installing ubuntu on a laptop, it's an elonex dfy30, 2.4ghz intel mobile, 1gb RAM with SiS M661FX graphics.

i have managed to get an old copy of mandriva to install, so i could get info... but really would prefer ubuntu.

basically at the prompt screen if i simply select try ubuntu without installing or install ubuntu it goes to a screen with scrolling text, and then just stops! there is a pic of this as the first attachment below. here i can ctrl-alt-del to reboot.

i have tried with the options: acpi=off noapic nolapic and nomodeset in various combinations, but i get another screen of text as in attachment 2 :( but this time i have to manually reboot.

i have also tried editing the line after "quiet splash --" and adding vga=878 as per the wiki page here (http://en.wikipedia.org/wiki/VESA_BIOS_Extensions#Linux_video_mode_numbers) and this gives me an error saying i've used an incorrect code and a list of alternatives, the ones i have tries either have the same result as sttachment 1 or i just get a blank screen :(

i have also tried:

video=sisfb

and

video=sisfb:mode:1024x768x32,rate:70,mem:4096

both with the same result as attachment 1.


this is all rather frustrating... but i'm hoping that with a little perseverance and some of your help i can get this up and running :)

from mandriva here is the output from lspci -nn and my Xorg.conf:


[dan@localhost ~]$ lspci -nn
00:00.0 Host bridge [0600]: Silicon Integrated Systems [SiS] 661FX/M661FX/M661MX Host [1039:0661] (rev 11)
00:01.0 PCI bridge [0604]: Silicon Integrated Systems [SiS] SiS AGP Port (virtual PCI-to-PCI bridge) [1039:0003]
00:02.0 ISA bridge [0601]: Silicon Integrated Systems [SiS] SiS963 [MuTIOL Media IO] [1039:0963] (rev 25)
00:02.1 SMBus [0c05]: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller [1039:0016]
00:02.5 IDE interface [0101]: Silicon Integrated Systems [SiS] 5513 [IDE] [1039:5513]
00:02.6 Modem [0703]: Silicon Integrated Systems [SiS] AC'97 Modem Controller [1039:7013] (rev a0)
00:02.7 Multimedia audio controller [0401]: Silicon Integrated Systems [SiS] AC'97 Sound Controller [1039:7012] (rev a0)
00:03.0 USB Controller [0c03]: Silicon Integrated Systems [SiS] USB 1.1 Controller [1039:7001] (rev 0f)
00:03.1 USB Controller [0c03]: Silicon Integrated Systems [SiS] USB 1.1 Controller [1039:7001] (rev 0f)
00:03.3 USB Controller [0c03]: Silicon Integrated Systems [SiS] USB 2.0 Controller [1039:7002]
00:04.0 Ethernet controller [0200]: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet [1039:0900] (rev 91)
00:09.0 CardBus bridge [0607]: ENE Technology Inc CB1410 Cardbus Controller [1524:1410] (rev 01)
01:00.0 VGA compatible controller [0300]: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter [1039:6330]



# File generated by XFdrake (rev 256990)

# ************************************************** ********************
# Refer to the xorg.conf man page for details about the format of
# this file.
# ************************************************** ********************

Section "ServerFlags"
#DontZap # disable <Ctrl><Alt><BS> (server abort)
AllowMouseOpenFail # allows the server to start up even if the mouse does not work
#DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
Disable "dri"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/input/mice"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName ""
HorizSync 29.5-59
VertRefresh 60-77

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "Silicon Integrated Systems [SiS]"
BoardName "SiS old series-based cards"
Driver "sis"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection


So, any ideas/suggestions/give up!? much appreciated

thanx :)

plus: i have installed debian (for about 5mins!) and now puppy linux as well with no problems!?!? why not ubuntu?? I have tried the alternative CD AND the DVD? all with the same result :cry:

gobbledigook
July 16th, 2010, 09:18 AM
*bump*

dino99
July 16th, 2010, 09:24 AM
actual kernel directly deal with X, so no need of xorg.conf: rename it or delete it

you can try to boot with: nomodeset and/or noacpi, nolapic, noapic, irqpoll (and remove quiet splash to see what happen)

gobbledigook
July 17th, 2010, 01:07 PM
you can try to boot with: nomodeset and/or noacpi, nolapic, noapic, irqpoll (and remove quiet splash to see what happen)

already tried this, as listed in my post... in different combinations, all the same result, either attachment 1 or 2 !

other ideas?

this is really starting to suck rancid ****! i'v e used ubuntu for years and never had so much trouble and so little HELP!

have tried xubuntu today and has the same result! downloading pclinuxos at the moment as it is mandriva based so might work....