View Full Version : [ubuntu] My Sansa Fuze suddenly turned 'read only'.

July 10th, 2010, 03:38 AM
It worked fine with the base install of 10.4 but somewhere along the way it stopped working and became read only.

Autodetect and MTP modes cause only the Fuze to show up in Rhythmbox. However the track numbers are all wrong and some things are garbled. MSC mode, which I used in the past, shows the Fuze and card both in Rhythmbox and on the desktop. However it's in read only mode.

Any thoughts?

July 10th, 2010, 03:40 AM
Does the sd card have a little switch on it and is it set to lock.

July 10th, 2010, 03:48 AM
Have you tried formatting the SD card in Gparted and then using slapping it in the Fuse and letting it recreate the filesystem

July 10th, 2010, 06:01 AM
i had this problem too, just remount it or replug it in with MSC mode.

update: i now have the same problem too. It must be spreading, lol.

July 10th, 2010, 09:18 AM
UMS devices will commonly be mounted as read-only if the file system is damaged. Doing a fsck can sometimes find and repair problems that cause this.

July 20th, 2010, 04:37 AM
I'm sorry it took me so long to get back to this. I've been too busy with work to play with it.

The file system does appear to be corrupt on the Fuze.

GParted had this to say when I attempted to check it:

GParted 0.5.1

Libparted 2.2
Check and repair file system (fat32) on /dev/sdf1 00:00:00 ( ERROR )

calibrate /dev/sdf1 00:00:00 ( SUCCESS )

path: /dev/sdf1
start: 0
end: 7683071
size: 7683072 (3.66 GiB)
check file system on /dev/sdf1 for errors and (if possible) fix them 00:00:00 ( ERROR )

dosfsck -a -w -v /dev/sdf1

dosfsck 3.0.7 (24 Dec 2009)
dosfsck 3.0.7, 24 Dec 2009, FAT32, LFN
open: No such file or directory


I tried resetting the Fuze to factory settings but that didn't help.

I'm at a loss as to what to do now.

I welcome any thoughts you all might have.

July 20th, 2010, 04:08 PM
Bump for the morning people. =)

February 28th, 2011, 04:36 AM
You need to reformat the entire device by going to settings>system settings>format.
Just worked for me.

February 28th, 2011, 06:04 AM

July 1st, 2012, 04:45 PM
Reformatting worked for me as well.