PDA

View Full Version : [SOLVED] MBP 5,1 Drivers worked before, not anymore :'(



tjw09003
July 8th, 2010, 08:22 PM
A couple of months ago I installed Ubuntu 9.10 on my MBP 5,1
After the install I used "Hardware Drivers" window to install the broadcom 4322 drivers. It worked easily.

Now I reformatted the system, and reinstalled ubuntu 9.10 on my mbp for reasons I won't go into.

Wireless doesn't work, as expected but when I got in "Hardware Drivers" to get wireless working it says "No proprietary drivers are in use on this system".

Any Ideas why? Remember, It all worked flawlessly before...

linuxopjemac
July 8th, 2010, 08:47 PM
You have to hook your Mac up to the internet with a cable connection and do:


sudo apt-get update

Then try again with Hardware drivers

tjw09003
July 9th, 2010, 12:33 AM
That did nothing with the "Hardware Drivers" window :D

It's still not showing any devices for proprietary drivers. On My last install the broadcomm, nvidea, and some other devices showed up on the list to enable the drivers. This time there is nothing

alexmurray
July 9th, 2010, 04:26 AM
Try manually installing the bcmwl-kernel-source package from software center.

tjw09003
July 9th, 2010, 09:58 PM
after restarting the system the broadcomm drivers should up in the list. For the nvidia drivers i just went to the official Nvidia download page http://www.nvidia.com/Download/index.aspx?lang=en-us , downloaded and installed.

It all works good now :D