View Full Version : [SOLVED] Problem starting "shred" command in Knoppix

July 8th, 2010, 04:11 PM
Greetings all.

I have used Knoppix several times before to wipe some drives but for some reason it's not working as planned this time. I am able to successfully boot into Knoppix and open up a shell from the ADRIANNE screen reader, but when I try to shred the drive by typing the following for the SATA hard drive:

shred -vfz -n 5 /dev/sda


shred -vfz -n 5 /dev/sda0


shred -vfz -n 5 /dev/sda1

(You get the idea) the blinking cursor prompt just goes down one line and keeps blinking; nothing happens.

Any enlightenment would be much appreciated.


July 8th, 2010, 04:30 PM
You may want to try asking this question in the Knoppix forum .....


This being an ubuntu forum and all, just a thought

July 8th, 2010, 04:32 PM
You are exactly right! ;) I actually just figured it out on my own.
Thanks for the Knoppix forum reference.

July 8th, 2010, 04:53 PM
Glad to hear you got it resolved,
Now that you've piqued our curiosity, what was the problem / solution?

July 20th, 2010, 04:59 AM

Actually, the problem was that the hard drive I was trying to shred wasn't mounting at all.
Shredding a different drive worked like a charm.

Ciao for now! ;)

July 20th, 2010, 07:07 AM
Wait, what? Why the hell were you trying to ask a question about Knoppix in the Ubuntu forums...