View Full Version : [all variants] iMac G4 wont recognize lunux based disk's

July 8th, 2010, 05:15 AM
I have a iMac That I am trying to wipe the hard drive and install some flavor of ubuntu, however when I press the C key to boot from cd/dvd it does not recognize any of the linux based disks I have. I have tried DBAN, ubuntu 10.4, xubuntu 10.4, and kubuntu 10.4 all but strait ubuntu should work however none will boot. I tested one of the OSX install disks that came with the computer and it booted fine. Is there some step that I am missing or is this machine as big a piece of crap that I think it is.

System Specs:
Processor: 800 MHz PowerPC G4 (7450)
Graphics: nVidia GeForce 2 MX with 32MB of DDR SDRAM (15")
RAM: 256MB of PC133 SDRAM

Jackson Tan
July 8th, 2010, 06:59 AM
Which Ubuntu or Linux CD did you use? PowerPCs need a different CD from the regular ones on Ubuntu's website. For Ubuntu, you can download the CD image from here: https://wiki.ubuntu.com/PowerPCDownloads.

July 8th, 2010, 08:13 AM
Firt make sure you re using PPC ISOs not distros for X86 nor AMD

Second , many imacs are cranky when it comes to booting from burned disks. Always burn the CDs at the slowest speed possible.

Hope this helps

July 8th, 2010, 08:40 AM
I wanted to Install Ubuntu but have no idea if the machine will support it, So im looking at kubuntu. I also tried to run DBAN=http://www.dban.org/

July 8th, 2010, 06:17 PM
havce a look here . Make sure you are using a PPC ISO


I am running this on a g3 imac 350 Mhz with 768 Meg or RAM on the standard 7.5 Gig drive, and it sings.