View Full Version : [ubuntu] No Sound and Media Players Don't

July 7th, 2010, 12:28 PM
Only a few minutes ago, my sound just seemed to disappear while I was listening to some Dream Theater.

The onboard sound is disabled in the BIOS as I'm using another card.
Rhythmbox won't play anything. Starting a song just leaves the progress bar sitting at the start.
Sound preferences shows everything up at full. I tried modding the volume, but I can't move it (It moves for like a millisecond then hits 100% again).

It's a C-Media sound card. It was working perfectly prior to a few minutes ago.

What's goin' on here?

I'm using some combination of PulseAudio and ALSA. PulseAudio is installed and I believe that's my primary 'driver'.

July 7th, 2010, 04:54 PM
Start your Media Player in terminal (just type in rhythmbox, or amarok, banshee, or whatever you're using), and watch what the terminal readout is. Chances are that PulseAudio quit on you. The unfortunate bit, is that the only way I've found to fix it, is to purge PA, and then reinstall it, and hope it doesn't quit for a while. I've found guides on how to fix PA permanently, but they never worked for me.

July 8th, 2010, 12:06 AM
elliot@Apollo:~$ rhythmbox
Nothing after that, even if I attempt to play a song.

July 8th, 2010, 05:19 AM
Try this:

killall pulseaudio
or reboot