View Full Version : [SOLVED] 10.04 install black screen after one minute

July 4th, 2010, 03:27 AM
I am installing 10.04 on a HP pavilion. I have downloaded the ubuntu-10.04-desktop-i386.iso (live CD). When I try to boot or install from it, the screen shows the "ubuntu" with the red dots for a minute and then a black screen with no action from the hard drive or the CD drive. I think it should be asking what language I want but presing enter does nothing.
I have been using Ubuntu since 2006 and after yesterday's repartition I installed 6.06 from a live CD so I know I can install from a CD.

July 4th, 2010, 03:29 AM
Try the alternate cd, it's probably not playing nice with yer video drivers.

July 4th, 2010, 07:17 AM
As suggested above by CharlesA, but you could also try some of the workarounds here:


Look towards the bottom of the post where oldfred posts links that may help you.

Good luck!

July 4th, 2010, 04:31 PM
Thank you, CharlesA.
I had started with the alternate CD but it was corrupted and had repartitioned my hard drive before it got to the corrupted part. I downloaded the alternate file this time doing the md5sum on the .iso file and made another CD, did the md5sum on the CD. Installed OK.

Booted 10.04 but a few seconds in the screen went blank again. Booted again in recovery mode, selected low graphics and it worked.

Thank you also, Rubi1200.
I will check into your suggestions to change the boot options.

I will report back my results.

July 4th, 2010, 05:51 PM

Thank you, CharlesA and Rubi1200.

I edited /etc/default/grub
Found the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
Changed it to: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=1"
And rebooted.

July 4th, 2010, 06:08 PM
You are more than welcome! I am glad we were able to help you resolve this.

Feel free to visit and post questions here anytime.


Also, mark your thread Solved by using the Thread Tools near the top of the page so that others can benefit from your experience.

November 3rd, 2010, 09:25 AM
Disclaimer: Do at your own risk. I used the information here:
and added my own steps based on trials and errors I experienced. Try at your own risk. All the credit goes to the author of above article.
The instruction here was correct but still not clear/complete for a newbie. So here is what I did to correct my 澱lack screen at the boot for HP Pavilion ze4904us. It appears that this was caused by the Intel video card. The problem was that after trying to reboot from a live CD, the initial installation pages of Ubuntu Lucid Lynx (10.04.01) was not appearing and a black screen would appear and not go away. Here is how I corrected it:
1- Insert CD and boot from the CD
2- Press F6 as the first purple screen is coming up and you get the Ubuntu 9.04 like menu for the languages
3- Press enter to select English (or your language)
4- use the arrows to choose the option 的nstall Ubuntu
5- Press F6 again, another menu opens up (nomodeset is one of the options but don稚 chose anything), press escape to get rid of this menu
6- boot option line is now appearing on the screen, below the menu choices
7- use the arrows to only erase the words 賭uiet splash
8- Insert one of the choices mentioned here:
* Older Intel video card: i915.modeset=1 or i915.modeset=0
* nVidia: nomodeset
* Generic: xforcevesa
the first one worked for me (i915.modeset=1)
9- press enter and now you can get passed the black screen and install Ubuntu Lucid Lynx 10.04.01
10- go ahead and re-boot after the installation is complete but keep your finger on the 鉄hift button as it is coming up. This will bring up the GRUB menu to help you edit your boot options.
11- press 兎 to edit the GRUB file
12- use the arrows to delete 賭uiet splash again and insert the choice you had from above making sure all the other words and spaces are unchanged.
13- press CTRL button and x at the same time to re-boot. You should now be able to boot passed the black screen
14- you have to make these changes permanent in the grub file or you would have to do this every time. The file is in the /etc/default/ directory but you can稚 edit it there and needs sudo permission
15- start a terminal session and enter gksudo gedit /etc/default/grub
16- the grub file is now open in an editor and you can add your option (in my case i915.modeset=1) to the end of this line GRUB_CMDLINE_LINUX_DEFAULT=拝uiet splash . Note that you are not erasing the 賭uiet splash, you are adding. save and exit the file
17- Terminal should still be open, type in sudo update-grub, hit enter, enter your password and hit enter again. It should work like a charm.