View Full Version : [SOLVED] Xubuntu resets permission to Firewire on Restart

July 2nd, 2010, 01:02 PM
It seems Xubuntu keeps on resetting the permission settings for the 1394 driver after I restart. Each time I have to sudo thunar and change it to Read & Write, but it changes it back to none after the restart. I was wondering why that is and what would be the best way to stop this from happening?

Thanks in advance!

July 3rd, 2010, 06:06 PM
Hi and welcome to the forums!

What are the default permissions of the device?

ls -al /dev/name
where name is the name of the device.

If the video group has read/write permissions then simply add your user to the video group:

sudo gpasswd -a user video
where user is your login name.

Log out and log back in.

Otherwise you have to create an udev rule. Check out the community doc:
the ArchLinux wiki:

If you are unsure how to write the rule, open a terminal and post the output of:

sudo udevadm info -a -p $(sudo udevadm info -q path -n /dev/name)
Replace name with the name of the device.

You have to create a new file for the rule, run:

gksu mousepad /etc/udev/rules.d/99-custom-1394.rules
to create the file and open it in the text editor.

To set the permissions you need something like:

KERNEL=="raw1394", GROUP="video", MODE="0664"

NOTE: This sets read/write permissions for root and the video group and read permissions for others, so you may have to add your user to the video group.

July 12th, 2010, 08:29 PM
That worked perfectly! Thanks for the help.

July 12th, 2010, 08:31 PM
You're welcome!

Please mark this thread as [SOLVED].

At the top of the page, click the "Thread Tools" Menu and then "Mark this thread as Solved".