PDA

View Full Version : Can't compile Moonlight project in MonoDevelop



testalucida
June 27th, 2010, 01:59 PM
Hi all,
when compiling a simple Moonlight project the following error occurs:


Error: Could not add reference 'gtk-sharp, Version=2.12.0.0, Culture=neutral, PublicKeyToken=35e10195dab3c99f' to 'moon5.xap': Assembly not available for Moonlight / Silverlight 2.0 (in Mono 2.4.4) (moon5)Here the result of dpkg -l | grep gtk-sharp:



ii gtk-sharp2 2.12.9-4 GTK# 2.10 suite, CLI bindings for GTK+
ii gtk-sharp2-examples 2.12.9-4 sample applications for the GTK# 2.10 toolki
ii gtk-sharp2-gapi 2.12.9-4 C source parser and C# code generator for GO
I'm running Lucid and I've installed both MonoDevelop and Moonlight from repository (lucid/main).

What's going wrong here?
Thanks for any advice

Regards
testalucida

slavik
June 27th, 2010, 02:50 PM
try installing the -dev library.

testalucida
June 27th, 2010, 05:10 PM
Hi Slavik
which -dev library do you mean?

slavik
June 27th, 2010, 05:38 PM
slava@dogbert:~$ apt-cache search gtk-sharp
gtk-sharp2-gapi - C source parser and C# code generator for GObject based APIs
libgtk2.0-cil - CLI binding for the GTK+ toolkit 2.12
libgtk2.0-cil-dev - CLI binding for the GTK+ toolkit 2.12
gtk-sharp2 - GTK# 2.10 suite, CLI bindings for GTK+
gtk-sharp2-examples - sample applications for the GTK# 2.10 toolkit
libanculus0.3-cil - utility library for CLI projects
monodoc-anculus-manual - compiled XML documentation for libanculus-sharp
slava@dogbert:~$

Looks like you need libgtk2.0-cil

testalucida
June 27th, 2010, 05:54 PM
no :(
result of apt-cache search is exactly like yours

slavik
June 27th, 2010, 07:25 PM
did you install the package?

testalucida
June 28th, 2010, 06:54 PM
dpkg -l | grep libgtk2.0-cil shows:



ii libgtk2.0-cil 2.12.9-4 CLI binding for the GTK+ toolkit 2.12
ii libgtk2.0-cil-dev 2.12.9-4 CLI binding for the GTK+ toolkit 2.12