View Full Version : [ubuntu] U10.04 does not boot consistently.

Randy Schilling
June 24th, 2010, 09:24 PM
My problem is this. U10.04 does not boot consistently; i.e., it
generally takes 1, 2 or 3 failed boot attempts before the system boots U10.04.
U10.04 seems to run just fine if i'm fortunate enough to boot into her.

My system is an Intel EM64T Pentium D running XP, Fedora13 and U10.04;
both Linux installations are their 64 bit versions. I have not encountered
any problems with my F13 installation.

The live cd containing Ubuntu-10.04-desktop-amd64.iso forewarned that there
could be problems because it too did not boot consistently. I checksummed
this and all my live installation cds.


I installed XP on primary (hd0,0) sda drive, then F13 on (hd1,0) sdb with grub on sdb1
(I wanted to put grub on sdb's mbr but F13's installer did not provide the sdb option.
It provided options sdb1 and sda; previously i installed grub to sda but that screwed
everything up, i guess because it messes with XP's boot loader.),
and lastly, i installed U10.04 on (hd2,0) sdc without a boot loader.

My plan was to add an entry for U10.04 to F13's grub. I'm not an expert on grub but I was able to follow grub's manual well enough and use F13's entry in grub for a guide. Here is what I added to the file menu.lst of F13's grub:
Title Ubuntu-10.04-desktop-amd64
root (hd2,0)
kernel /boot/vmlinuz-2.6.32-21-generic ro root=UUID=ac7d53d6-5531-4663-9555-a4620c30f5b0 rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM_LANG=en-us.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rhgb guiet
initrd /boot/initrd.img-2.6.32-21-generic
The arguments of the commands kernel and initrd are files which I found in Ubuntu's filesystem, analogous to F13's entry in grub. I'm less certain of the options I used in the kernel command. ro for read only seems to be a standard option. The 8+4+4+4+12 hex sequence following UUID= is analgous to F13's entry; I found Ubuntu's hex seqence at the top of the window containing
her filesystem, figured there could be just one such sequence in play. The remaining options of kernel command are taken verbatim from F13's entry.

When booting the system, the U10.04 option appears correctly in grub's menu screen, you can select XP and it'll boot evertime, likewise for F13. If you select Ubuntu, you will boot successfully in 30% to 50% of your attempts.

That's all the detail I have to offer. If you need more information just let me know what it is.

Could there be a hardware incompatibility causing U10.04 to boot inconsistently? That would be surprising because U8.04 worked just fine on my system for a long time.

I also tried the 32 bit installation of U10.04. I didn't follow through with the installation
because the live installation cd containing the 32 bit U10.04 did not boot consistently.

What else might cause such boot inconsistencies beside hardware and a possible error in my additions to grub's menu.lst?

Thanks for taking time with this and regards - Randy

Randy Schilling
June 25th, 2010, 04:20 PM
This time it took 2 failed boot attempts before I booted into U10.04. One halted at the screen with 5 progression dots, the next didn't make it to that screen, stalling at a blank black screen.

Ubuntu's Upgrade Manager does not seem to be working. It indicated 194 updates available.
I hit install, entered my password, got message "Reading Package Information. Building Data Structures"
but nothing seems to happen after that.

On the positive side, Firefox imported my list of Favorites from XP very nicely.

Should I trust that Ubuntu installed correctly and completely?