View Full Version : [SOLVED] 10.04 freezes at splash screen

June 14th, 2010, 09:55 PM
Hello all,

I upgraded a week or so ago to 10.04, and everything was working fine. Then suddenly a few days ago the computer froze at the splash screen on startup. Thinking it was just some sort of neurotic, temporary issue, I restart again, but no luck -- same problem.

In terms of what I changed before the problem happened, I don't recall changing any system settings. On possibility is my changing things to skip the login screen and go strait to my account, but I believe I had done that a few shutdown/restarts before. Also, things freeze after the last dot turns red, if that helps anyone.

I apologize for my newbie-ness. I'm getting more comfortable with using Linux every day, but the internals of it still mystify me!

June 16th, 2010, 02:17 PM
Same thing has been happening to me for the past two weeks or so, I don't think there was a new kernel release since then, but I honestly haven't been paying attention to it. It's happening to me on both a 64-bit machine and 32-bit.

June 16th, 2010, 02:21 PM
Hey guys, I was having the same problem, and what fixed it for me was the nomodeset option in the grub boot line.

Check out this post. (http://ubuntuforums.org/showthread.php?t=1439638&page=2)

June 16th, 2010, 02:24 PM
you can remove splash too

June 17th, 2010, 05:16 PM
Hmm, well that SORT of solved the problem. If I turn off the splash screen like that thread suggests, and also add "nomodeset", I get a screen saying Ubuntu is running in low graphics mode. I looked at the error files, and the relevant bit in the xserver log seems to be:

(==) Log file: "/var/log/xorg.o.log", Time *whatever*
(==) Using config file "/etc/X11/xorg.conf"
(==) Using config directory: "/usr/lib/X11/xorg.conf.d"
Parse error on line 34 of section ServerLayout in file /etc/X11/xorg.conf
"reen0" is not a valid keyword in this section
(EE) Problem parsing the config file
(EE) Error parsing the config file

Fatal server error:
no screens found

I tried the option to reset x-server settings to default, and found the same sequence of startup events happened and the same log files were produced. So the problem seems to be with my xorg.conf file. After looking at that, the "reen0" the error file refers to seems to have something to do with a line involving "Screen0".

Ack, any idea how to fix this???

June 21st, 2010, 09:27 PM
That means that your xorg.conf is screwed up. You should regenerate it by doing the following:

sudo dpkg-reconfigure xserver-xorg

June 21st, 2010, 09:41 PM
if the above doesnt work then rename the /etc/X11/xorg.conf file. Strictly speaking, you dont need the xorg.conf file unless you are using a proprietary driver such as nvidia.

If you have a nvidia graphics card - rename your xorg.conf file, then regenerate a new file via

gksudo nvidia-settings

June 22nd, 2010, 02:44 AM
Thanks, sowelie and davidmohammed! I think it was actually that last method that worked for me. I really appreciate all the help guys (and gals?), so thanks again!