View Full Version : [ubuntu] ubuntu on UL30A-X5K?

June 11th, 2010, 10:50 AM

I want to purchase a new laptop and I think I'll go for asus UL30A-X5K.
The problem is that I didn't find information about the linux compability.
Is there someone who has tried this model with lucid pls?
And do you have an idea why UL30A-X5K is cheaper than UL30A-X5, is this 'kindle' a bad thing?
sorry for the bad english..


July 8th, 2010, 02:22 AM
Did you end up buying this laptop? I'm actually thinking about buying the same model. The next model up has bluetooth and discrete Nvidia graphics, however there is no Linux support for the switchable graphics yet, so I'm sticking to this one and saving $100.

Would like to hear any reports as well.

July 28th, 2010, 11:08 PM
yes I ended up purchasing ul30a-x5k
I kept windows since one month, but I had enough with it.
I tried cygwin, gvim, etc.. but it is not really practical.
So I've just installed with a dual boot ubuntu 10.04 x64 on it.
Everything seems to work well.
I did not check bluetooth, I never used it, and the touchpad was defected, so I am using a wireless mouse.
No problem for installation neither except the weird boot order in bios, usb stick is not recognized as removable device but hard drive. I spent a half hour to realize it :)
if you need some reports, pls advice. I could paste.
It is a fast computer, but the material is not high quality.
It is normal for the price.

July 28th, 2010, 11:33 PM
I ended up buying the laptop as well. I swapped the original HD with an SSD and installex 10.04 x86.

Everything works fine except the brightness adjustment. The brightness slider works sometimes, and even when it does, I can only scroll it with my scrollwheel, as trying to drag and drop the lever causes it to disappear.

Using the keyboard shortcut to adjust brightness works in very large increments, and you have to first adjust it up to adjust it down, very confusing.

July 29th, 2010, 12:07 AM
yes, you are right.
I have the same problem apparently, it is too bright or not enough. for the sound also, fn keys doesn't work properly.
I think it is better to keep windows and to ssh to linux on the desktop. or to put ubuntu with virtual box.
and try again with 10.10 :)