PDA

View Full Version : 10.04 downloaded mismatched eclipse junit libraries



java_man
June 11th, 2010, 02:54 AM
I just upgraded from Ubuntu 8.04 to 10.04. This included an upgrade of Eclipse to Galileo (3.5.2). I have a java project with way over a thousand lines of code that was building and running fine on the previous Eclipse. The new Eclipse will not build the project with this error : Project is missing required library: 'org.junit4_4.1.0/junit-4.1.jar'. The Eclipse plugin library contains org.junit4_4.5.0.v20090824/junit,jar - obviously not what Eclipse is looking for. Is it possible that Ubuntu/Eclipse shipped mismatched libraries that have brought my development to a full stop? I'm a little upset - I have things to get working. I either need to modify the build path or get the right jar. Supplemental question: Where can I get real Eclipse support?