View Full Version : [ubuntu] Kensington Expert Mouse Pro not working

June 9th, 2010, 01:42 AM

I have just installed ubuntu 10.04 on my HP Pavilion dv2000 Notebook (Dual Boot Windows XP) and I'm trying to use the Kensington Expert Mouse Pro (which is actually a USB trackball, Model# 64213).

Everything I could find online tells me it should just work out of the box and all I'd have to do was configuring the buttons. However, this is NOT the case! I plug it in, nothing happens. A Belkin USB mouse I plugged in as a test worked fine immediately. The USB ports are functional...

Any suggestions? Do you require more system information?

Cheers, Greg

November 30th, 2010, 04:38 AM
Hi Greg.

I just wanted to chime in as another Kensington Expert Mouse user. Mine (model #K64325) did work just fine out of the box. (I'm using it right now!) I use it with my netbook which is now running 10.10, but it worked under 10.04 as well. It has also worked on my desktop since 10.04.

The two main buttons work fine, and I'm currently following some tutorials to try to get more of the extra buttons to work. (I'll be able to get the top buttons to work as forward and back for web browsing and Nautilus, but I'm really hoping to get the "chords" to work so I can have some semblance of a middle button...)

No solution for you, I'm afraid. :cry: Have you tried lately with 10.10?