View Full Version : [ubuntu] Laptop Monitor Fine, but External Monitor shaky with lines.

June 7th, 2010, 06:20 AM
I have a dual-boot system of Windows Xp, and Ubuntu.
I installed Ubuntu 10.04 using wubi.
I have an ATI Mobility Radeon X1300
Lenovo Thinkpad T60 with dock.
1.5GB Ram
Intel Centrino Duo.

On my laptop display, ubuntu displays properly. However, on my external monitor, I get a shaky screen with lines. This didn't happen in Ubuntu 9.10. I checked to make sure the correct driver pagkage was installed, and it was. Is there any way to fix this?

P.S. I have 2 vga ports. ON the dock, it displays, but it is hazy. I also tried the laptop vga port, and it is also hazy. Can someone help me?

June 7th, 2010, 08:06 AM
Same here, also Lenovo Thinkpad Z61p. External monitor is recognized correctly but the sync appears incorrect.
No docking station, just the external monitor on VGA port.

June 8th, 2010, 12:13 AM
I also tried on my thinkpad's internal vga port, but same problem.

Is there any way to set the refresh rate from 60hz

June 15th, 2010, 01:01 PM
I have the same problem, worked fine before now, not so much

So help me!

June 16th, 2010, 01:55 PM

June 27th, 2010, 09:48 PM
I have the same problem but with some different hardware, I'm using a Emachines E625 using dual boot with Windows XP and Ubuntu 10.04 with Ati Radeon X1200. I've tried googling how to fix, but it seems that is not supported. I tried other linux distro, puppy linux and slax and they work ok on external screens. There are big differences in between distros but for my personal use if external screens don't work with Ubuntu, I'm settling with Slax, that is the one more near to ubuntu.
Unless we hear of a way of sorting this out, that's my way around.

June 29th, 2010, 08:05 PM
Hey prabal I finally got to a way to eliminate the shaky lines in external monitor completely, at least from my laptop. I followed the directions on http://ubuntuforums.org/showthread.php?t=1470952 which suggest adding a line to grub that gave me the solution. Now with the fix I'm using definitely Ubuntu 10.04 which have more interactive tools than the others distro that I mentioned before. Hope this help you too.