View Full Version : [ubuntu] 10.04 install from USB - gets stuck

June 2nd, 2010, 01:20 PM

Am new to this. Looked through the search for an answer, but can't find one, hence the post.

I have a laptop with a broken CD drive and am attempting to install via USB.

I've followed the instructions, successfully downloaded the ISO, USB pen image maker, made the image and booted onto it. However, once booted when I select the option to install on the harddisk it keeps getting stuck at the same place, just after the keyboard selection dialog. Nothing is displayed on screen to indicate why.

The laptop has an AMD x64 chip and I wonder if I'm downloading the wrong image either on the ISO or where the USB image is created. I note where the USB image is created there are only i386 options (but I'm not sure what I'm looking for). Confusingly the image on the USB drive does appear to make Ubuntu work perfectly.

I have previously had Ubuntu working on this machine, although it was alongside Windows and I installed it using the "install alongside windows" option. Once booted from the USB stick I can access the internet or can access a 1Tb USB drive, so I'm sure there are ways round it.

Any help gratefully received.


June 7th, 2010, 10:01 AM
Should it help anyone, I found the cause of this problem - the USB stick in use.

I tried another brand of USB stick and it worked as expected.

I don't think there was anything wrong with the stick itself as since I've run checks on it, but there was "something" that was halting the build as it inspected the disk configuration.

The one that didn't work was a Fuji 4Gb. The one that did work was an unbranded 2Gb.

June 16th, 2010, 03:42 AM
You rock. I have been fighting this, tried every other ISO and a bunch of other much more arcane options, but after your experience I popped it onto a different, older, USB stick (went from a PNY mini-attache 4GB to a PNY optima 2GB) and it worked perfectly. Thanks again.

July 17th, 2010, 08:20 AM
Curious... same problem with my PNY Mini-Attache 4GB. Freezes on Language Selection for Keyboards. I'm able to quit back to the desktop and REISUB out (on the live-install mode). Last I've heard Text Mode install is gone on Ub10.04, so I didn't bother looking around.

Guess I'll burn a disc for 10.04 instead.