View Full Version : [ubuntu] get pwuid_r ( ) failed due to unknown user id

June 2nd, 2010, 09:40 AM
On a fresh install of Lucid I get the error message
GLib - WARNING **: get pwuid_r ( ) failed due to unknown user id
at start up
I'm not sure, but firefox & synaptic won't start up from the desktop & I think this may have something to do with it. From the command line 'gksudo synaptic' gives an error of pid already in use

June 2nd, 2010, 10:27 AM
I got that. Restart? Worked for me.

June 2nd, 2010, 10:34 AM
I always get it & wonder if it's related to the other problems.

June 2nd, 2010, 12:27 PM
I have no problem with sudo, firefox or synaptic.

I always get it

I've only had it once or twice (maybe only today) and a reboot resulted in a perfect boot. However I did write over my Karmic install with my Lucid install, so maybe this is something to do with a corrupt home directory. Maybe create a new user and see if that helps?

June 2nd, 2010, 12:48 PM
Thanks - I'll give that a try. Does anyone know what a pwuid_r( ) is, or why it should fail ? I had the message once on my netbook, & it wouldn't boot up; but on restarting it was all right.

Ken Jannot
June 10th, 2010, 09:01 PM
I get that message at the tail end of my installation when I try to install (with a cd) 10.4 over 9.10 -- it starts the installation, then that message pops up. The installation goes no further. Can anyone tell me why this would be?

August 19th, 2010, 06:05 AM
I'm having this problem too with an old Asus laptop. I'm going to try via USB and see if that works.

August 19th, 2010, 06:22 AM
laptop won't boot from USB... grrr

Same error from live-cd too. Everything seems to freeze when this happens, too.