PDA

View Full Version : [ubuntu_mobile] 10.04 on external hard drive



Clement_User
June 2nd, 2010, 03:52 AM
I have a pretty annoying problem going on with 10.04 right now that I know wasn't present in 9.04; it's probably related to the change from Grub to Grub2.

Background
I am trying to install Ubuntu on my external hard drive because of I need the portability. With 9.04, I just installed it, made sure my bootloader was on the external (via the advanced menu right before the final step before install), and voila! It was great. However, I later needed to reformat the drive and now I'd like to install 10.04 (since it's newer and cooler :P).

The problem
The problem right now is not particularly with Ubuntu, it's with the bootloader. I have Ubuntu installed (I obviously haven't been able to test it). However, I can't boot into Ubuntu because Grub says "No such partition" and gives me a rescue prompt. I'm fairly new to Linux, and I'm completely clueless about bootloaders.

Info about the Setup
I have three partitions on this external hard drive. One is a NTFS primary partition, and another is a FAT32 primary. The Linux install was done by Ubuntu into a new extended partition, with the necessary logical ext4 and swap partitions.

What I've tried
I'm pretty desperate. I wanted to do this all by myself, but I've already wasted over 10 hours on this. :( At first, I naively tried the way I had done it with 9.04. The install ended up quitting because the bootloader install would fail ("Sorry, but there was an error and it was not possible to install the bootloader at the specified location"). I made sure it wasn't a one-time thing, and moved on. After much mucking around, I decided to try installing the OS without a bootloader. Obviously, I would have to install it later, and this is where I spent most of my time: trying to find a set of instructions that worked properly. Finally, I found something that seemed to work to install Grub2. The instructions came from the Ubuntu wiki here (https://help.ubuntu.com/community/Grub2#Reinstalling from LiveCD). Method 1 didn't work because update-grub would complain that no device was found. Method 2 looked annoying and difficult. I used Method 3 and everything installed without a hitch. Well, actually, there was a minor problem where I couldn't execute grub-install --recheck because it complained about being a read-only file system (apparently some files are removed with rm during a recheck). I thought I was done, but no... Now it just doesn't work.

Any help would be very appreciated. Thanks in advance.

Herman
June 2nd, 2010, 04:20 AM
This example here, Ubuntu / Windows Dual Boot (http://members.iinet.net.au/%7Eherman546/p24.html) , shows you how to dual boot in a computer with more than one hard disk.
In your case since you have partitions in your other disk that you want to keep, you would want to choose 'manual partitioning' instead of 'use entire disk', when you get the the partitioning. Then select the partition you want to install Ubuntu in.
What you should particularly look for in the example, are the illustrations about how to install the boot loader to the same hard disk you install Ubuntu in. As far as that installation example is concerned, it's irrelevant what kind of interface the hard disk you choose to install Ubuntu in uses in between the disk and the rest of the computer, USB, SATA, or IDE, so almost anyone should be able to see what to do from that web page. (I hope).

Regards, Herman :)

Clement_User
June 2nd, 2010, 04:29 AM
This example here, Ubuntu / Windows Dual Boot (http://members.iinet.net.au/%7Eherman546/p24.html) , shows you how to dual boot in a computer with more than one hard disk.
In your case since you have partitions in your other disk that you want to keep, you would want to choose 'manual partitioning' instead of 'use entire disk', when you get the the partitioning. Then select the partition you want to install Ubuntu in.
What you should particularly look for in the example, are the illustrations about how to install the boot loader to the same hard disk you install Ubuntu in. As far as that installation example is concerned, it's irrelevant what kind of interface the hard disk you choose to install Ubuntu in uses in between the disk and the rest of the computer, USB, SATA, or IDE, so almost anyone should be able to see what to do from that web page. (I hope).

Regards, Herman :)





Thanks for the reply. However, I have already tried this path, as noted in my original post. Your method worked with 9.04, but for some reason or another, doesn't work for me with 10.04. At 93%, the installer complains that it can't install a bootloader at the specified location and tells me to choose another place. I have made sure through tests that it isn't just a one time occurrence.

Herman
June 2nd, 2010, 09:22 AM
:-k Okay, I assume you have installed your USB drive's GRUB to MBR in the USB and not just to the partition (boot sector).

One thing that strikes me as odd about method 3 here, Reinstalling from LiveCD (https://help.ubuntu.com/community/Grub2#Reinstalling%20from%20LiveCD), is they ask you to run 'update-grub' before they say to run 'grub-install /dev/sdx'.

The reason why I think that's strange is because if you don't have GRUB installed, the grub-install command creates for you a brand new /boot/grub directory and fills it up with GRUB files from /usr/lib/grub/i386-pc.
If you run update-grub before you run grub-install, and you have no /boot/grub yet, I don't know if it would work. How could it put your grub.cfg in /boot/grub when no /boot/grub exists yet?
It could be that the how-to you followed needs a little edit, but I'm not sure yet, I should test it myself first to make sure but I'm feeling a little lazy right now. I presume whoever wrote that did test it, so I'm hesitant to say it's incorrect. Maybe it hasn't yet been tested as rigorously as you did though, (with no GRUB installed at all). Let's just say I have concerns about the sequence of the commands you followed, (for now).

I don't really want to put you through the chroot process again, to repeat the same commands, (unless you want to). This time with a /boot/grub directory full of GRUB files, the update-grub command should work. (Assuming that's your trouble).

Another way to do things would be to try downloading a Parted Magic Live CD (http://partedmagic.com/), which contains Super Grub Disk and Super Grub2, burn it to a CD and use that to boot your Ubuntu with, or just download a Super Grub2 disk (http://www.supergrubdisk.org/).
That should boot your Ubuntu for you, if it doesn't, try GRUB2 How To Boot From CLI Mode (http://members.iinet.net/%7Eherman546/p20/GRUB2%20How%20To%20Boot%20From%20CLI%20Mode.html).

When you have Ubuntu booted, you will still need to at least run 'sudo update-grub', and possibly grub-install too, (wouldn't hurt).
Personally, I prefer the other command 'sudo grub-mkconfig -o /boot/grub/grub.cfg' instead of 'sudo update-grub', but use whichever you prefer.

Hopefully (if I have guessed correctly), that will fix it.

Herman
June 2nd, 2010, 09:39 AM
UPDATE: Okay, I tried deleting my /boot/grub and then running 'sudo update-grub', and it did create a new /grub directory with a grub.cfg file in it, so I was wrong.

I still think it would be worth a try if you can just boot Ubuntu with a Super Grub Disk and get updates and just try installed GRUB again it should work.

Herman
June 2nd, 2010, 08:19 PM
I couldn't execute grub-install --recheck because it complained about being a read-only file system (apparently some files are removed with rm during a recheck). I thought I was done, but no... Now it just doesn't work. The option ' --recheck ' after the grub-install command was for 'Probe a device map even if it already exists'.

The /boot/grub/device.map file was a plain text file that contained a list of drives in GRUB notation and their equivalents in Linux notation, like this,

(hd0) /dev/sda
(hd1) /dev/sdb
I looked in a couple of my up-to-date Lucid Lynx installations and I cannot find any device.map file in /boot/grub anymore, there is a 'drivemap.mod' though.
I was able to find the /boot/grub/device.map files in a couple of my other Lucid Lynx installations which are not up to date, and also in a Karmic Koala installation.

That reinforces my idea that either chrooting or booting, (whichever you find easiest), and getting updates will likely fix your problem.

Clement_User
June 2nd, 2010, 10:14 PM
The option ' --recheck ' after the grub-install command was for 'Probe a device map even if it already exists'.

The /boot/grub/device.map file was a plain text file that contained a list of drives in GRUB notation and their equivalents in Linux notation, like this,

(hd0) /dev/sda
(hd1) /dev/sdb
I looked in a couple of my up-to-date Lucid Lynx installations and I cannot find any device.map file in /boot/grub anymore, there is a 'drivemap.mod' though.
I was able to find the /boot/grub/device.map files in a couple of my other Lucid Lynx installations which are not up to date, and also in a Karmic Koala installation.

That reinforces my idea that either chrooting or booting, (whichever you find easiest), and getting updates will likely fix your problem.

I wouldn't mind chrooting, but how would I go about that process? Do you just want me to update-grub again? I can, but I'd like to know. :confused:

Clement_User
June 3rd, 2010, 04:07 AM
Hm. Interesting. Everything will install fine if the hard drive has no partitions to begin with. I might just have it erase the entire disk and create my required partitions later. I'll report back on how well that works.

Wish me luck... :KS

Herman
June 3rd, 2010, 04:20 AM
Hm. Interesting. Everything will install fine if the hard drive has no partitions to begin with. I might just have it erase the entire disk and create my required partitions later. I'll report back on how well that works.It shouldn't make any difference whether or not there are other partitions in your hard disk besides the one(s) you are installing Ubuntu in. Please yourself though, if you think that will help.

I'm on time limit right now, (my lunch break is almost timed out), but I'll go through how to chroot with you as soon as I can.

Clement_User
June 3rd, 2010, 04:37 AM
It shouldn't make any difference whether or not there are other partitions in your hard disk besides the one(s) you are installing Ubuntu in. Please yourself though, if you think that will help.

I'm on time limit right now, (my lunch break is almost timed out), but I'll go through how to chroot with you as soon as I can.

You were right :(
The install would even claim to install the bootloader though...

I'm guessing my problem here is that when I configure grub, it assumes my external is hard drive #2. However, once grub boots up on the external, it considers the external to be hard drive #1. I think everything would be fine if I can just boot into Ubuntu and run update-grub from the external hard drive. I downloaded a Super Grub Disk and burned it. Neither the Grub-legacy or Grub2 versions will autodetect Ubuntu, so I'll be trying out the command-line way that you have in your previous post, Herman. Thanks a lot for helping me so much already. :)

joshedmonds
June 3rd, 2010, 04:54 AM
If anyone can get Grub2 working, it's Herman.

If anyone can't, it's me.

I had the same problem and after quite a bit of work reverted to legacy grub which works without issue. See this thread http://ubuntuforums.org/showthread.php?t=1367875

The final solution for me was not exactly as detailed in my last post, but you can use it as a guide to the process:


sudo mount /dev/sdb1 /mnt
sudo mount --bind /dev /mnt/dev
sudo chroot /mnt
apt-get install grub
sudo grub
root (hd1,0)
setup (hd1)
exit
^D
sudo cp /media/old9.04install/boot/grub/menu.lst media/thisinstall/boot/grub/
sudo gedit /media/thisinstall/boot/grub/menu.lst
exit

I chroot'ed into the external drive and installed legacy grub, ran grub and installed to the external drive. Press Ctrl+D to exit the chroot. You may need to edit the /boot/grub/menu.lst file on the external drive. The easiest way is to use the uuid ('sudo blkid' for a listing).

efflandt
June 3rd, 2010, 05:15 AM
Perhaps your system has trouble with the new partition alignment.

https://wiki.ubuntu.com/LucidLynx/ReleaseNotes#Partition%20alignment%20changes%20may %20break%20some%20systems

I have that issue with my HP a530n with Asus mobo from 2004. When I first installed 64-bit 10.04 LTS on a 500 GB USB WD Passport to test it, it booted fine on 2 different laptops, but my desktop dropped into grub rescue with error: unknown filesystem (it is ext3).

So I installed 10.04 to a 160 GB USB WD Passport which I knew was able to boot 9.10, and that dumped into grub rescue with error: file not found. Strangely from grub rescue I could ls (hd0,3/ and it would show the directories. But if I tried to ls (hd0,3)/boot I got an ascii happy face symbol. And if I tried to do the same for /boot/grub I got "file not found".

Then I stumbled on the release notes. So I removed and recreated the partition w/gparted in 9.10 and used the partman/alignment=cylinder kernel parameter for the install, and added that to /etc/default/grub, and 10.04 booted fine from the 160 GB USB drive on the troublesome PC. So I used that parameter installing 64-bit 10.04 to an existing partition on the 200 GB internal drive on that PC, and I am running from it now.

But I tried the same for the 500 GB USB drive, and it still drops to grub rescue with error: unknown filesystem, and ls sees all the partitions, but gets the same "unknown filesystem" for any of them. Although, regular grub 1.98 prompt from internal hard drive can read the first ntfs partition, it likewise gets unknown filesystem for the Linux ext3 partition at the far end. So my BIOS must still have some issue attempting to boot from a partition somewhere between the 200 GB and 500 GB points.

Note that when I boot from the USB drive, grub sees it as (hd0) and when I boot the internal drive with the USB drive attached, grub sees the external drive as (hd1). Linux itself has no trouble auto mounting ntfs and ext3 partitions on the 500 GB drive.

However, I have never seen "No such partition", so I do not know if that is a different error for a similar problem, or a different issue.

Clement_User
June 3rd, 2010, 04:48 PM
I tried Super Grub Disk, both grub2 and grub-legacy versions, but neither will allow me to boot Ubuntu from the commandline as Herman posted.

I'll try booting from the grub rescue prompt that I get after I appear to install grub.

Clement_User
June 3rd, 2010, 09:37 PM
I would really prefer to use Grub2 as it's newer technology, but I need the hard drive functional in around 5 days, and I won't have access to the hard drive for about 2.

Clement_User
June 3rd, 2010, 10:20 PM
Ah, the latest in my confusing saga...

From the Super Grub Disk based on Grub2, using the command line, I can use ls (hd1,1) and it will list my Ubuntu files. I can even clearly see vmlinuz and initrd.img. However, once I try to do
linux (hd1,1)/vmlinuz root=/dev/sdb1
It immediately says File not found. Help! :confused::confused:

Herman
June 3rd, 2010, 10:47 PM
It would be interesting to find out whether or not you can boot it with GRUB Legacy, from the Legacy GRUB Super Grub Disk, GRUB's Command Line Interface (http://members.iinet.net.au/%7Eherman546/p15.html#cli), because that would tend to indicate whether or not your problem has anything to do with updating from Legacy GRUB to GRUB2, or if it's likely to be some other problem. :)

Clement_User
June 3rd, 2010, 10:51 PM
It would be interesting to find out whether or not you can boot it with GRUB Legacy, from the Legacy GRUB Super Grub Disk, GRUB's Command Line Interface (http://members.iinet.net.au/%7Eherman546/p15.html#cli), because that would tend to indicate whether or not your problem has anything to do with updating from Legacy GRUB to GRUB2, or if it's likely to be some other problem. :)

Trying that out now.

Clement_User
June 3rd, 2010, 11:01 PM
Nope, doesn't work. Grub-legacy fails on
kernel /vmlinuz root=/dev/sdb1 It reports Error 2 and says something like "bad file".

Herman
June 3rd, 2010, 11:07 PM
:) Oh, GRUB Error 2, thank you, that could be a useful clue, at least it gives me something to look up, here's the info I have collected on GRUB Error 2 (http://members.iinet.net.au/%7Eherman546/p15.html#2_).
Not that it's very helpful, but nevertheless, it's still a clue.

Herman
June 3rd, 2010, 11:11 PM
Do you have access to any other computers you can try booting it from to try to test whether there's some kind of issue, (as efflandt suggested) to do with the PC you're using of if the problems seem related to the particular USB drive and the OS installed in it?

sgosnell
June 3rd, 2010, 11:14 PM
Clement, are you absolutely, positively certain that you have a good install CD? It's not at all uncommon to get a bad download, a bad CD burn, or both. Do an MD5sum check of your .iso file, and if that passes, boot from the install CD you made and have it check itself for errors. Most hung installations are caused by faulty CDs, IME.

Herman
June 3rd, 2010, 11:18 PM
:) Another, obvious step that we didn't try is just to run a simple file system check, I overlooked that, and that often fixes problems like this, however, given that you have tried re-installing several times, it seems unlikely to do any good. I don't think Ubuntu would require a file system check every time before it will boot a fresh installation.
If the file system check completes without any problems, we can rule out a bad file syste m from the list of possible problmes, and if the file system check fails, (unlikely I think), feedback from the file system check might give us a few clues.

Try Running a filesystem check with GParted (http://members.iinet.net.au/%7Eherman546/p10.html#Running_a_filesystem_check_with_GParted_)- a user friendly GUI method
or
Running a filesystem check on an ext3 filesystem (http://members.iinet.net.au/%7Eherman546/p10.html#filesystem_check_on_an_ext3_filesystem) - from the command line, live CD
(whichever you prefer). :)

Herman
June 3rd, 2010, 11:21 PM
Clement, are you absolutely, positively certain that you have a good install CD? It's not at all uncommon to get a bad download, a bad CD burn, or both. Do an MD5sum check of your .iso file, and if that passes, boot from the install CD you made and have it check itself for errors. Most hung installations are caused by faulty CDs, IME.:) Yes, sgosnell has a good point there, that could be worth investigating too, Check the integrity of your download - Why integrity check your downloaded .iso? (http://members.iinet.net.au/%7Eherman546/p17.html#Why_integrity_check_your_downloaded_.iso)

Clement_User
June 4th, 2010, 12:01 AM
I've downloaded the iso 5 times already, each time I checked it against an MD5. Stuff happens when you're desperate.

I'll try on another computer.

Clement_User
June 4th, 2010, 12:24 AM
O.M.G. I am an idiot.

I'm posting from Ubuntu on my external hard drive from my other computer.

Apparently Ubuntu doesn't like custom-built, powerful PC's. :p

Thanks to all who helped (esp. Herman! You tried so much & taught me a lot along the way), and sorry for not trying this sooner.

Herman
June 4th, 2010, 01:02 AM
O.M.G. I am an idiot.
I'm posting from Ubuntu on my external hard drive from my other computer.
Apparently Ubuntu doesn't like custom-built, powerful PC's. :razz:No, you're not an idiot and it's perfectly reasonable to expect your Ubuntu in a USB-connected drive to be bootable in (almost) any computer.

I also like to assemble my own computers, and my newest one has the Intel(R) Core(TM)2 Quad CPU Q8400 @ 2.66GHz, which was regarded as pretty good at the time, and I don't think it's too long out of date yet. It booted Lucid Lynx in 3.03 seconds in my OCZ Vertex SSD, but I was too late to add that to the thread, 'Post your Lucid bootcharts or boot times! (http://ubuntuforums.org/showthread.php?t=1343305), the thread closed before I had a chance.
Here's the URL for my bootchart to prove it, http://members.iinet.net/~herman546/p1/ocz-lynx-lucid-20100430-18.png (http://members.iinet.net/%7Eherman546/p1/ocz-lynx-lucid-20100430-18.png)

Having said that though, Linux does have the slight disadvantage that hardware isn't often specifically designed to run Linux, but the hardware is made and then Linux developers figure out how to get Linux to run on it.
It's not quite fair to say that 'Ubuntu doesn't like custom-built, powerful PC's'.
That reminds me, I recently read a news item, Nearly every supercomputer runs Linux (http://mymail.buyhttp.com/link.php?M=6423605&N=1875&L=30394&F=H). :)

Announced earlier today, the 35th list of the top 500 supercomputers contains few surprises, just that Linux has almost total domination of the list.How about posting some of your hardware details, and it may even help someone to help you solve your problem with the particular PC you have, if we're lucky.
The Ubuntu Live CD will boot in your PC that the USB install couldn't boot from, so if you could run 'sudo lshw' it might be interesting,

sudo lshw Regards, Herman :)

pelao00
June 4th, 2010, 01:20 AM
You cannot install an OS in an extended partition !!!! The main system files of an OS should always be installed in a primary partition.

Also... I'm not sure but I think that an OS (or at least one if dual boot) have to be install in the first partition of the disk, or else u can get grub errors (boot and stuff)... not sure though

Clement_User
June 4th, 2010, 01:59 AM
@pelao00, I didn't install Ubuntu to the extended, it did so itself. Not my fault there, though you could be right.

@Herman,
1) lol that's fast. I need to get an SSD sometime, my HD is the slowest part of my system.
2) I'm guessing that supercomputers don't have GRUB problems though... :biggrin:
3) I'm too lazy right now to go back downstairs to boot up Ubuntu, or even really to go to the live CD, but I know my hardware well enough:
Core i7-920 OC to 3.5GHz
Corsair 6Gb Ram, also OC'd
Asus P6T Deluxe v2
WD 1Tb hard drive (wish I could OC this :P )
Nvidia GTX 260 (also OC'd, but software OC so it shouldn't be important)

Herman
June 4th, 2010, 03:10 AM
:) Thanks!
Nice hardware!
That's probably enough info for now. ...

Clement_User
June 4th, 2010, 04:17 AM
Just when I thought it couldn't get any weirder...

I can now boot from my normal computer! :popcorn:
I really don't know why.
Two things happened that could have done stuff:
1) I updated Ubuntu and update-grub was run again.
2) I updated my BIOS.
I did both around the same time and didn't test in between so I have no clue which is the more important.

Well, I'm pretty happy right now. :)

Herman
June 4th, 2010, 04:34 AM
:) Hooray!
I'm happy for you too!
You kept on trying until you solved your problem!
Congratulations and well done!

EDIT: Threads and Links I was reading,
Intel Core i7 On Linux (http://www.phoronix.com/scan.php?page=article&item=intel_core_i7&num=1)

[all variants] Intel Core i7 (http://ubuntuforums.org/showthread.php?t=995231)

Asus P6T Deluxe V2: Kernel or BIOS bug? (http://ubuntuforums.org/showthread.php?t=1186549)

crispyrob
June 13th, 2010, 02:56 PM
Hi All - I'm at my wits end trying to get 10.04 Grub2 to boot via legacy grub on an external hard drive. This issue is very similar to Clement_User's problem at the start of this thread.

Due to a lack of space on my internal hard drives, and wanting to try various distros as they come out,
I currently run Ubuntu 8.04 on an external hard drive, with multiple partitions so I can test other distros.

When I installed 8.04, I installed the bootloader on the MBR of the >external< drive, so in order to boot into
linux I hit F12 on startup to select the list of boot devices and select the external hard drive as the boot device

Before I completely blow away a perfectly good, working install of 8.04 I want to be able to play with 10.04
for a while to ensure that it all works properly with my hardware.

Under linux on my system, the external hard drive appears as device "sdc".

In order to test 10.04, I installed it to partition sdc10, and also installed GRUB2
to /dev/sdc10 when asked where to install the bootloader.

I then modified my 8.04 menu.lst to chainload into 10.04 Grub2:

title Ubuntu 10.04
root (hd0,9)
savedefault
chainloader +1

However, this gave me the error: "Error 13: Invalid or unsupported executable format"

After some research I followed the instructions in a tutorial file from here:
http://ubuntuforums.org/showthread.php?t=1504824 (post #2 by darkdragn)

and modified the call to:

title Ubuntu 10.04
root (hd0,9)
kernel /boot/grub/core.img
savedefault
boot

So now I don't get "Error 13" but I get "Error 15: File not found" instead.

This is why I think I'm having issues with Grub2 - because when I >boot< from the
external hard drive, it becomes "hd0" to "legacy" grub, however when Grub2 installed,
it thinks my external drive is "hd2"

When I look at the new grub.cfg, it shows that it's trying to boot from "hd2":

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Ubuntu, with Linux 2.6.32-21-generic' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
insmod ext2
set root='(hd2,10)'
search --no-floppy --fs-uuid --set bf586786-b2f1-4df2-834b-829912912ff8
linux /boot/vmlinuz-2.6.32-21-generic root=UUID=bf586786-b2f1-4df2-834b-829912912ff8 ro quiet splash
initrd /boot/initrd.img-2.6.32-21-generic
}

It did this even after setting the HD boot priorities in my bios so that the external hard drive was first.

I tried editing this file (grub.cfg), changing the occurrences of "hd2" to "hd0", but this had no effect
and I still get "Error 15" (presumably because there are other file that are referencing hd2)

How do I get the Grub2 bootloader to assume that my external drive is hd0? I'm going to assume that even if I
install the bootloader to my external drive, it will still assume it's hd2 and I'll end up with a totally
unbootable system.

Here is the layout of my external hard drive "sdc" (from "fdisk -l" via live cd):

Device Boot Blocks Id System
/dev/sdc1 330296400 7 HPFS/NTFS <- NTFS (windows data)
/dev/sdc2 77883089+ f W95 Ext'd (LBA)
/dev/sdc5 26218048+ 83 Linux <- ext3 (linux data mounted as /data in 8.04)
/dev/sdc6 2104483+ 82 Linux swap / Solaris <- swap
/dev/sdc7 10490413+ 83 Linux <- 8.04 Install
/dev/sdc8 * 9767488+ 83 Linux <- Mythbuntu 9.04
/dev/sdc9 19535008+ 83 Linux <- Sabayon
/dev/sdc10 4883728+ 83 Linux <- 10.04 Install
/dev/sdc11 4883728+ 83 Linux <- Linux Mint 7

Any help would be very appreciated...
Thanks,
Rob

sgosnell
June 13th, 2010, 03:12 PM
You should be able to boot to the external HD by setting it as the first boot device in your BIOS. I don't think you can make grub assume it's hd0, you'll have to do something else to configure grub for your other problems.

crispyrob
June 15th, 2010, 11:58 AM
Hi - I don't have a problem booting from the external drive - that's how I get into my current (8.04) install. The issue I'm having is booting into the 10.04 I installed into partition "sdc10", chainloading from the 8.04 installed (legacy) grub installed on the mbr of the external drive.

When I boot via the external drive it becomes "hd0" in my system, but the grub2 install assumes that the external hard drive is "hd2", so the bootloadeer fails with error 15 - file not found.

crispyrob
June 18th, 2010, 02:43 PM
UPDATE: I finally got 10.04 to boot!

Since the legacy GRUB I'm using is from my 8.04 install, on a hunch I thought maybe it couldn't read the EXT4 partition I created for 10.04.
So, I reinstalled 10.04 but this time chose EXT3 instead of EXT4 and it's
all good now...