View Full Version : [ubuntu] WUSB54g V4 -- I have to use ndiswrapper to get it to work

June 1st, 2010, 09:18 PM

I have a Linksys WUSB54G V4 wireless adapter and the only way it will successfully connect to the internet in through ndiswrapper. It says that it connects to the router, but it doesn't connect to the web. I have tried all types of static settings. With ndiswrapper it works perfectly.

Any ideas?

June 2nd, 2010, 02:07 PM
I have the same device WUSB54G external wifi. Using Lucid I can connect to my router, I can use the web but only for a while, after a period of time it gets disconnected and the only way to re-connect is to disable networking and enable it again and sometimes I have to reboot. With ndiswrapper this disconnection problem can be solved? Is there any other workaround?

June 2nd, 2010, 07:30 PM
With ndiswrapper all problems are solved with this adapter. Let me know if you need help setting it up. In theory you shouldn't have to use it; it should work out of the box.

June 10th, 2010, 09:28 PM
I have downloaded and installed the ndiswrapper package and rebooted the machine. The problem persist, after a while I got disconnected. I should do something else, change some configuration? Please, let me know if you can help me out to configure the device. Thanks!

June 11th, 2010, 01:37 AM
Use the "Using Windows Drivers" part of this official help file: https://help.ubuntu.com/10.04/internet/C/troubleshooting-wireless.html

Note: Remember to open the .exe you download from Linksys with the Archive Manager

Let me know if you have any questions.


June 17th, 2010, 08:08 PM
I followed willz06jw's instructions and now is working fine without any disconnection or packets lost. Thanks for the help!

September 25th, 2010, 09:21 AM
I installed the linux-fireware-nonfree package. After that the hardware was recognized after boot.

Fernando Negro
December 29th, 2011, 12:27 PM
There's no need to use "ndiswrapper" and follow all those complicated instructions.

You can easily solve the problem, simply by switching to a different kernel (http://ubuntuforums.org/showthread.php?p=11572146#post11572146).