PDA

View Full Version : [ubuntu] sound play on both laptop and external speakers



faelken
June 1st, 2010, 07:42 PM
I looked around the settings on Ubuntu and I cannot prevent sound from being played on my laptop speakers when external (more powerful) speakers are plugged in. Windows automatically defers all sound output to the external ones as soon as it is plugged in.

How can I fix this?

faelken
June 1st, 2010, 08:10 PM
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC880 Analog [ALC880 Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC880 Digital [ALC880 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 6: Si3054 Modem [Si3054 Modem]
Subdevices: 1/1
Subdevice #0: subdevice #0

Codec: Motorola Si3054
Codec: Realtek ALC880

lidex
June 2nd, 2010, 02:32 AM
Sounds like a jack-sense issue. What is the make/model of the PC?

faelken
June 2nd, 2010, 07:18 AM
Its an old Alienware M17. Basically it has 3 jacks - two outputs and one mic. input. I've seen the other post but what should I put into the command lines?

lidex
June 3rd, 2010, 01:55 AM
That's a tough one. Try this. Using a Terminal="Applications->Accessories->Terminal"
Open this file for editing:

gksudo gedit /etc/modprobe.d/alsa-base.conf
Insert this line at the bottom:

options snd-hda-intel model=3stack
Save. Close. Reboot. Check your levels in alsamixer.

alsamixer
Press <F6> to select the correct soundcard.
Press <F3> to show playback levels. <F4> selects capture levels [or use <Tab>]
Use the left/right arrow keys to select and up/down arrow keys to change levels. <M> to mute/unmute.
Go to "System ->Preferences ->Sound" and make sure the correct soundcard is default.

Other options to try:

options snd-hda-intel model=w810
options snd-hda-intel model=uniwill
options snd-hda-intel model=auto
Only one line at a time!

faelken
June 3rd, 2010, 12:08 PM
Thanks it worked for 3stack not w810

lidex
June 4th, 2010, 05:35 AM
Great. Please mark the thread as solved using 'Thread Tools' up top.