View Full Version : [ubuntu] compaq 615 Brightness

June 1st, 2010, 12:24 PM
I have installed ubuntu 10.04 on my laptop (Compaq 615) and from the beginning the Fn buttons that control the brightness have not worked. They show the brightness being changed on the top right hand corner but nothing changes.

I have googled the problem but with no avail.

The "solutions" which I have tried includes changing the HAL settings, (i.e. vendor and models etc)

I have included the line acpi_backlight=vendor into the grub config file.
This worked for a while as when I unplugged my charger the brightness went down (This it did not previously do)

However after a few restarts the backlight is now bright when running on battery and dim when running on power.

All I want is to be able to change the brightness like I was able to do in 9.10

June 1st, 2010, 02:10 PM
"add to panel">"brightness applet"

Does that change brightness? If it does, the problem is with your computer understanding the key input of the fn combo. If it does not, the problem is with how it interacts with the backlight itself.

June 2nd, 2010, 11:54 AM
No that does not help, but thanks

June 3rd, 2010, 06:28 PM
can anyone help?

July 15th, 2010, 02:25 PM
have the same problem... strange behaviour:

- switching on w/ battery or plugged in -> full brightness (100%)
- plugging in (if on battery before) -> reduced brightness (let's say 70%), then unplugging -> even more reduced brightness (let's say 50%)
- plugging out (if plugged in before) reduced brightness (50%), plugging in again (70%)
- using keys w/Fn-Key -> "up" shows onscreen display (shows full brightness, nothing changes)
- using keys w/Fn-Key -> "down" no onscreen display at all, whatever I do thereafter...

Hope someone can help as this is leaving a very bad impression (installed the machine for a first time Ubuntu/Linux user....) Help, please!

July 15th, 2010, 03:43 PM
solved. see here: https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/555122/comments/55

good luck!

August 3rd, 2010, 09:46 AM
Thanks that worked for me