PDA

View Full Version : [SOLVED] Change default program for Edit Image button on eog (Eye of Gnome) image viewer



Paddy Landau
June 1st, 2010, 10:26 AM
When I view an image with eog (Eye of Gnome), I see a button "Edit Image".

The button takes me to F-Spot.

How can I change this to go to GIMP?

laidback
June 1st, 2010, 11:24 AM
I think you require to change the default image viewer which can be done as follows:-

right click on image
choose Properties (last in list)
now select the Open with tab, 4th along
from the list presented choose which viewer/package to use when you click on this type of file

You may need to set this preference again should you want to open a variety (different types of file, e.g. .png, .jpg etc) with your preferred application as I think the preference is applied individually to each type. So you could have .jpg with Eog and .png with FSpot etc. But you only need to set each type once.

In case there is a difference I'm using v9.04, you're on 10.04 I believe.

Paddy Landau
June 1st, 2010, 11:50 AM
Thanks, but that's not quite what I'm after.

I want eog to remain the default application for viewing images. What I want changed is the "Edit Image" button when I have eog open.

I'm not sure if 9.04 has that option. See the screenshot of the button.

http://ubuntuforums.org/attachment.php?attachmentid=159007&stc=1&d=1275389414

laidback
June 1st, 2010, 11:57 AM
No it doesn't, all I get is the Edit button with no options.

laidback
June 1st, 2010, 12:14 PM
I've just loaded my trial 10.04 version and see what you mean. Nice touch that button. I suspect that there is a setting somewhere in the hidden directory for Eog but I've had a quick look in mine (~/.eog) and couldn't see anything obvious. Perhaps a search on the web for Eog might help.

laidback
June 1st, 2010, 01:31 PM
Looking in /usr/share/eog doesn't produce anything obvious either.

Paddy Landau
June 1st, 2010, 01:47 PM
I suspect that there is a setting somewhere in the hidden directory for Eog but I've had a quick look in mine (~/.eog) and couldn't see anything obvious. Perhaps a search on the web for Eog might help.
I have Googled but come up with nothing. The help and the eog website both give no clue.

I suspect that it's built into the program, rather than as a parameter, which would be a pity.

BTW, the directory is ~/.gnome2/eog. Nothing there refers to f-spot.

I wonder where I could file a change request?

philinux
June 1st, 2010, 01:53 PM
I've no edit image button as I've replaced f-spot with gthumb.

From eog I use File>Open With

Paddy Landau
June 1st, 2010, 01:58 PM
From eog I use File>Open With
Oh, that's a good workaround, thanks.

philinux
June 1st, 2010, 02:00 PM
Oh, that's a good workaround, thanks.

Or you could mess around here. Replace with gimp.desktop Not sure if it will work.

laidback
June 1st, 2010, 05:29 PM
Have a look at "Help" > "Get help online.." I don't expect you will find an answer but you can also ask a question, which might enable you to make a request.

Paddy Landau
June 1st, 2010, 08:59 PM
Or you could mess around here...
Thanks for the idea. Sadly, EOG didn't like gimp.desktop.

Paddy Landau
June 1st, 2010, 09:05 PM
Have a look at "Help" > "Get help online.." I don't expect you will find an answer but you can also ask a question, which might enable you to make a request.
Great idea! Having failed with Google, I've asked this question (https://answers.launchpad.net/ubuntu/+source/eog/+question/113149).

philinux
June 1st, 2010, 09:12 PM
Great idea! Having failed with Google, I've asked this question ("").

Well for certain f-spot will be replaced by shotwell in Maverick.

Paddy Landau
June 3rd, 2010, 11:41 AM
Bizarre this is!

Phil suggested (http://ubuntuforums.org/showthread.php?p=9393665#post9393665) that I change the setting in gconf-editor, and that didn't work for me.

My question on Launchpad (https://answers.launchpad.net/ubuntu/+source/eog/+question/113149) gave the same answer.

So, I tried again, and this time it worked.

I guess that I mistyped the first time.

Thank you Phil and Launchpad for the answer!