PDA

View Full Version : [ubuntu] Flash Plugin not working for Google Chrome



pbandy34
June 1st, 2010, 03:13 AM
I've just upgraded to Ubuntu 10.4 and installed Google Chrome... The flash plugin won't work for some reason. I've installed it/uninstalled it a dozen times, but when I try to go to youtube in Chrome, it still tells me to install the plugin...

It works fine in Firefox.

Any thoughts?

lovinglinux
June 1st, 2010, 03:47 AM
Install FLASH-AID (http://flash-aid-extension.blogspot.com) extension for Firefox. It will remove conflicting plugins and install the proper flash version according to your browser architecture.

If you don't use Firefox or prefer to fix the problem from command-line, then see the Flash Optimization (http://firefox-tutorials.blogspot.com/2010/05/flash-optimization.html) section of Firefox optimization and troubleshooting thread (http://ubuntuforums.org/showthread.php?t=1193567).

bungee_hamster
June 7th, 2010, 10:44 AM
I tried Flashaid as firefox kept crashing when I was loading webpages with lots of ad boxes and videos and now I can't watch videos at all - get the dreaded message that I need to get the latest adobe flash player.
Almost ready to chuck my ubuntu box - total newbie, in need of help.

Ok - that's odd. tried the command line instructions & now I can watch videos but firefox still crashes when I load a music fanpage with ads, flashy stuff and videos. I assume there must be some kind of conflict but not sure how to find out what?

lovinglinux
June 9th, 2010, 12:55 AM
I tried Flashaid as firefox kept crashing when I was loading webpages with lots of ad boxes and videos and now I can't watch videos at all - get the dreaded message that I need to get the latest adobe flash player.
Almost ready to chuck my ubuntu box - total newbie, in need of help.

Ok - that's odd. tried the command line instructions & now I can watch videos but firefox still crashes when I load a music fanpage with ads, flashy stuff and videos. I assume there must be some kind of conflict but not sure how to find out what?

Use NoScript (https://addons.mozilla.org/en-US/firefox/addon/722/) to block unnecessary flash content.

bungee_hamster
June 21st, 2010, 06:14 PM
so I tried FlashAid but now I can't use the street view on Google Maps (in Firefox!)as it wants me to download Flash Player 10. Flashaid seemed to remove a load of stuff but also couldn't find various files and so didn't remove them. Any thoughts on why flash still doesn't work? What info do I need to check for?

lovinglinux
June 21st, 2010, 06:55 PM
so I tried FlashAid but now I can't use the street view on Google Maps (in Firefox!)as it wants me to download Flash Player 10. Flashaid seemed to remove a load of stuff but also couldn't find various files and so didn't remove them. Any thoughts on why flash still doesn't work? What info do I need to check for?

Is it only Google Maps' street view that isn't working? Can you watch YouTube videos?

Type about:config in Firefox address bar, then type plugin.expose_full_path in the filter, then double-click the same item in the results to make it true. Then type about:plugins in the address bar, find Shockwave Flash, copy the corresponding Path and Version and paste here.

milochen
October 19th, 2010, 08:15 AM
If all you want to do is to play flash on chrome,

You may try to install chrome extension easily to solve this problem.

More detail could refer here ...

http://milochen.wordpress.com/2010/10/19/play-youtube-easily-with-google-browser-in-ubuntu-10-04-64bits/

SpeedyGonsales
June 29th, 2012, 11:54 AM
I have 2 plugins for Flash in Chrome:


Name: Shockwave Flash
Description: Shockwave Flash 11.3 r31
Version: 11.3.31.109
Location: /opt/google/chrome/PepperFlash/libpepflashplayer.so


and


Name: Shockwave Flash
Version: 11.2 r202
Location: /usr/lib/adobe-flashplugin/libflashplayer.so


First just stopped working on last update to Chrome 20, in Chrome 19 everything worked fine. I disabled first plugin and now I have working Flash. Hopefully that will be solved soon.

nothingspecial
June 29th, 2012, 12:27 PM
Please create a new thread rather than bumping and old one to the top.

Closed.