PDA

View Full Version : [ubuntu] 10.04 LTS Installs as Server Only?



HDTimeshifter
May 29th, 2010, 10:48 PM
I burnt a 10.04 LTS disc when it was released and just tried installing on an old Pentium 2 400 MHz with 320 MB and two 10 GB drives. After rebooting, it comes up in text mode with a tty2 login. Did this install the server version only? Is there a command to launch the GUI shell? There were no options during the install to choose GUI or server version and I assumed this was the 32-bit GUI version and the install disc ran with the GUI during installation.

lisati
May 29th, 2010, 10:50 PM
Which version did you download? The "Desktop" version comes with a GUI, but the "Server" version doesn't.
If you downloaded and installed the "Desktop" version, which works on many laptops as well, it could be a graphics configuration issue.

HDTimeshifter
May 29th, 2010, 10:54 PM
ubuntu-10.04-desktop-i386.iso

The video card is an old Ati Rage Pro AGP, but I assume since the graphics came up fine on the live disc during install, it should not have had problems. I've been able to run this PC in 1600 x 1200 pixels under Win XP (although very slowly but not any slower than a P4 with only 128 MB that I just also installed XP on - that is why I decided to reformat and switch to Linux). My file server (1.3 GHz Athlon 496 MB RAM and on-board video) is running 32-bit Ubuntu 10.4 LTS desktop fine with limited 800 x 600 resolution. The P2 is the first PC I've tried a new install (as opposed to Internet upgrade) with the 10.04 LTS CD. I did verify the hash after burning the CD to make sure it was a good burn.

davidmohammed
May 29th, 2010, 11:20 PM
you said tty2 is displayed... if you press ctrl - alt - F7 does it switch to the correct gui display?

alternatively - login and type startx...

are any errors displayed.

HDTimeshifter
May 30th, 2010, 02:26 AM
Already reinstalled again, and now it boots in GUI mode, albeit at a low 800x600 resolution like my file server.

But thanks for the info - if it works at a decent speed, I'll wipe up XP on my P4 and install Ubuntu there, and if that defaults to the command line log-in, I'll try the Ctrl-Alt-F7 or startx...