View Full Version : [ubuntu] 10.04 loses mouse / keyboard inputs at random

May 28th, 2010, 09:08 PM
Hi folks,

I upgraded from 9.10 to 10.04 LTS last week (32 bit, gnome desktop, no desktop effects). The system was quite stable before the upgrade (it's usually on 24/7 with uptimes in the dozens of days), but ever since updating to 10.04, the system loses all mouse and keyboard input at random times.

I can still ssh into the system fine and reboot it in an orderly fashion from a laptop, but I'd rather that it wouldn't freeze like this in the first place ;-)

I've tried service gdm start / stop from an ssh session to see if it's an xorg-related problem, but sadly that did not help in recovering mouse / keyboard input.

I also tried unplugging and re-plugging the ps/2 keyboard and the usb mouse, but sadly that also didn't help.

I don't see any weird messages in dmesg, so it's not a kernel oops either it seems.

I'm using the proprietary nvidia driver if that matters.

Thanks in advance for any pointers to where to start debugging,


June 12th, 2010, 05:20 PM
I have a somewhat similar problem in that my keyboard will randomly go out after vastly differing time periods. Sometimes I can go for days without the problem, sometimes a few hours. Both my trackpad and USB mouse continue to work fine though.

For me, however, there is an additional problem. All of a sudden, windows won't move and menus won't click. I can maximize, restore and close windows, but not move them. Menus highlight when I click them, but won't pull down. Since I can't click the powerdown menu, I have to ctrl+alt+del to get to the shutdown window, which is the only keyboard command that works.

June 12th, 2010, 05:31 PM
I just updated my system to the mainline kernel after today's freeze, so far everything is looking ok.

2.6.35-020635rc1-generic #020635rc1 SMP Tue Jun 1 18:38:58 UTC 2010 i686 GNU/Linux

I'll post here if the system suffers any more freezes.

All the best, Uwe

July 4th, 2010, 12:33 PM
I have a similar issue after upgrade from 9.04 to 10.04.
My mouse works till the first login screen. After login the mouse icon disappears, but if I move the mouse I can see that the desktop icons get the focus and loose focus successfully, but the mouse icon is not visible.
I seem to be having a workaround. If I lock the desktop (using CTL+ALT+L) and then move the mouse then I can see the mouse icon and the mouse stays functional thenceforth.
I hope the above workaround helps.

July 12th, 2010, 06:19 PM
I have had a similar problem with the mouse focus. I solved it unplugging all my USB devices and plugging only the mouse and keyboard. I will try to plug the rest of devices later..

August 22nd, 2010, 05:59 AM
Sadly, right there with you guys. I also just upgraded to 10.04, and I'm impressed by a few of the features, but there's only so much I can explore.

My problem is that the keyboard and mouse will work at the login screen. I get to my desktop and my keyboard stops working. I tried both a wireless and a USB one with no luck. Then, after anywhere from 1-5 minutes, my trackball input buttons refuse to do anything. I can move the pointer around, but I can't click on hyperlinks, drop-down menus, or file folders. Most of the suggestions I've found so far don't make a lot of sense and might not apply anyway. Help?

August 22nd, 2010, 09:47 AM
Out of pure desparation, I upgraded my nvidia drivers to 256.xx manually. The system has been fine for

10:45:27 up 3 days, 12:37, 5 users, load average: 0.15, 0.31, 0.25

now, but that's not saying much as even with the old drivers, it managed an uptime of 2 weeks while we were on holiday (the system also serves as a dsl router / fw / file server while my son staid at home). However when we returned and I used the gnome desktop again, it froze within five minutes, requiring a hard reset.

I don't know if the latest nv drivers have helped solve or at least alleviate the problem, but things are looking good even with transmission running in the background (transmission has also been notorious in triggering a freeze a few minutes after it's started).

Also read this thread (about 80 pages already)


to find out what sorts of burning hoops people have tried to jump through in order to solve the issue or at least determine what might be causing it.