PDA

View Full Version : [ubuntu] [10.04] segfault in libc-2.11.1.so



beumont2
May 26th, 2010, 09:16 PM
Hello,

I have a fresh installtion of Ubuntu 10.04 with all updates downloaded and installed. Now I have installed some additional software from the repo which wont work. Like the mail-notification application ist just starting and the exiting:

Here are the errors please help:


May 26 17:50:13 workstation kernel: [ 2513.980384] mail-notificati[5584]: segfault at 15d ip 0758150b sp ad142aec error 4 in libc-2.11.1.so[7541000+153000]
May 26 17:52:00 workstation kernel: [ 2620.485744] mail-notificati[5656]: segfault at 373 ip 00a6550b sp b7590aec error 4 in libc-2.11.1.so[a25000+153000]
May 26 17:52:05 workstation kernel: [ 2625.689970] mail-notificati[5662]: segfault at 373 ip 050d950b sp b75a6aec error 4 in libc-2.11.1.so[5099000+153000]
May 26 17:52:09 workstation kernel: [ 2629.504395] mail-notificati[5667]: segfault at 373 ip 0717550b sp b75c0aec error 4 in libc-2.11.1.so[7135000+153000]
May 26 17:52:14 workstation kernel: [ 2635.248926] mail-notificati[5672]: segfault at 373 ip 03dae50b sp b7621aec error 4 in libc-2.11.1.so[3d6e000+153000]
May 26 17:52:21 workstation kernel: [ 2641.654951] mail-notificati[5677]: segfault at 373 ip 01e6350b sp b75e1aec error 4 in libc-2.11.1.so[1e23000+153000]
May 26 17:52:28 workstation kernel: [ 2648.988889] mail-notificati[5685]: segfault at 373 ip 028f850b sp b7705aec error 4 in libc-2.11.1.so[28b8000+153000]
May 26 17:52:32 workstation kernel: [ 2652.429959] mail-notificati[5690]: segfault at 373 ip 093bf50b sp b7530aec error 4 in libc-2.11.1.so[937f000+153000]
May 26 17:52:35 workstation kernel: [ 2655.990530] mail-notificati[5695]: segfault at 373 ip 0200c50b sp b7590aec error 4 in libc-2.11.1.so[1fcc000+153000]
May 26 17:52:40 workstation kernel: [ 2661.007439] mail-notificati[5700]: segfault at 373 ip 0825450b sp b753caec error 4 in libc-2.11.1.so[8214000+153000]
May 26 17:52:45 workstation kernel: [ 2665.670840] mail-notificati[5705]: segfault at 373 ip 0601f50b sp b7620aec error 4 in libc-2.11.1.so[5fdf000+153000]
May 26 17:57:55 workstation kernel: [ 2976.150595] mail-notificati[6508]: segfault at 373 ip 0376c50b sp b759faec error 4 in libc-2.11.1.so[372c000+153000]
May 26 18:01:40 workstation kernel: [ 3200.500560] mail-notificati[6687]: segfault at 373 ip 0413950b sp b7559aec error 4 in libc-2.11.1.so[40f9000+153000]
May 26 18:01:51 workstation kernel: [ 3211.605029] mail-notificati[6692]: segfault at 373 ip 07cca50b sp b7644aec error 4 in libc-2.11.1.so[7c8a000+153000]
May 26 18:36:28 workstation kernel: [ 5288.502789] gnome-commander[7042]: segfault at c66b5bc ip 03db58bb sp bfba8648 error 4 in libc-2.11.1.so[3d4a000+153000]
May 26 18:36:58 workstation kernel: [ 5318.762004] gnome-commander[7119]: segfault at 130adb94 ip 08c288bb sp bf80fc38 error 4 in libc-2.11.1.so[8bbd000+153000]
May 26 19:25:55 workstation kernel: [ 8256.307642] pdfedit[8551]: segfault at 79d ip 0046fe91 sp bf93cb88 error 4 in libc-2.11.1.so[400000+153000]
May 26 19:43:09 workstation kernel: [ 9290.322513] pdfedit[10651]: segfault at 79d ip 0067be91 sp bfb84838 error 4 in libc-2.11.1.so[60c000+153000]
May 26 19:58:12 workstation kernel: [10192.523281] pdfedit[10691]: segfault at 79d ip 003fde91 sp bf90aa88 error 4 in libc-2.11.1.so[38e000+153000]
May 26 22:09:47 workstation kernel: [18087.997369] mail-notificati[16511]: segfault at 15d ip 012d850b sp b75fbaec error 4 in libc-2.11.1.so[1298000+153000]

whit
July 24th, 2010, 05:24 PM
I'm getting a similar segfault with sed, after a dist-upgrade:

24 12:14:39 boot2 kernel: [11463.918370] sed[3281]: segfault at 1 ip b7773000 sp bff6174c error 6 in libc-2.11.1.so[b76bf000+153000]
24 12:14:39 boot2 kernel: [11463.924473] sed[3284]: segfault at 1 ip b7720000 sp bffd9b1c error 6 in libc-2.11.1.so[b766c000+153000]
24 12:14:39 boot2 kernel: [11463.951017] sed[3292]: segfault at 1 ip b77a3000 sp bfa4944c error 6 in libc-2.11.1.so[b76ef000+153000]
24 12:15:13 boot2 kernel: [11497.758172] sed[3399]: segfault at 1 ip b766b000 sp bff027dc error 6 in libc-2.11.1.so[b75b7000+153000]
24 12:15:13 boot2 kernel: [11497.775839] sed[3405]: segfault at 1 ip b76a8000 sp bfff6f8c error 6 in libc-2.11.1.so[b75f4000+153000]
24 12:15:13 boot2 kernel: [11497.785839] sed[3408]: segfault at 1 ip b76ea000 sp bfab048c error 6 in libc-2.11.1.so[b7636000+153000]

This in in trying to run "update-grub", which calls sed. I'm running a 2.6.34.1 kernel rather than stock, though (to work with the wireless of an Eee 1001P). But that kernel wasn't presenting and compatibility problems with Lucid programs until this today.

Eugene Morozov
September 24th, 2010, 10:37 AM
I got the same when tried to change settings of Gnome Commander. I go to Settings->Options->Programs->Add->type in whatever->OK. It crashes with this in syslog:

Sep 24 13:11:05 mookee-desktop kernel: [174968.694157] gnome-commander[6804]: segfault at c19f000e ip 07a99a04 sp bfa84c18 error 5 in libc-2.11.1.so[7a2c000+153000]I works fine with libc-2.9.so in Ubuntu 9.04 on another desktop.

dannyboy79
November 11th, 2011, 11:10 AM
i understand this is old BUT is there anything to fix the issue? I am getting on playback within VLS of a kdenlive encoded video using xlib264 and libfaac codec.


[38409.658295] vlc[19233]: segfault at 10b978f ip 00233914 sp bfa4bfa0 error 4 in libc-2.11.1.so[205000+153000]
[38490.243642] vlc[21232]: segfault at 111178f ip 0060b914 sp bf852b00 error 4 in libc-2.11.1.so[5dd000+153000]
[38592.503290] vlc[21690]: segfault at 111d78f ip 006f1914 sp bfeff440 error 4 in libc-2.11.1.so[6c3000+153000]
[39394.783077] vlc[2374]: segfault at 117978f ip 00393914 sp bfd392b0 error 4 in libc-2.11.1.so[365000+153000]


VLC is version VLC media player 1.0.6 Goldeneye

FFMPEG if it matters is this:

FFmpeg version SVN-r0.5.1-4:0.5.1-1ubuntu1.2, Copyright (c) 2000-2009 Fabrice Bellard, et al.
configuration: --extra-version=4:0.5.1-1ubuntu1.2 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --disable-stripping --disable-vhook --enable-runtime-cpudetect --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libdc1394 --enable-shared --disable-static
libavutil 49.15. 0 / 49.15. 0
libavcodec 52.20. 1 / 52.20. 1
libavformat 52.31. 0 / 52.31. 0
libavdevice 52. 1. 0 / 52. 1. 0
libavfilter 0. 4. 0 / 0. 4. 0
libswscale 0. 7. 1 / 0. 7. 1
libpostproc 51. 2. 0 / 51. 2. 0

oldmilwaukee
March 6th, 2012, 06:55 PM
This fixed it for me

rm -rf /var/cache/apt/*.bin