PDA

View Full Version : [ubuntu] Skype doesn't see USB phone....



simon0404
May 24th, 2010, 01:44 PM
Hello,

I can't get my USB phone to work in Skype....

When I go into Skype options, and into the Sound Devices menu, the only option it gives me is "PulseAudio (loca)l"

I have tried looking at USB devices in some other apps, and some do recognise that there is a USB audio device attached (the phone is a simple one with no keypad).....


I'd be most grateful for some assistance to get this working.

Many thanks,
Simon./

Chesamo
May 24th, 2010, 02:15 PM
What are the details of this phone? Is it a telephone in the conventional sense, or simply a microphone and speaker?

simon0404
May 24th, 2010, 03:44 PM
What are the details of this phone? Is it a telephone in the conventional sense, or simply a microphone and speaker?


It is just a microphone and speaker, which is held like a telephone handset.... no keypad etc...

I used to use it in windows, and it didn't need any software to work....

It is detected in ubuntu, and If I use the volume control, there are settings shown.

simon0404
May 25th, 2010, 10:10 AM
nudge

michaelA1330
May 25th, 2010, 10:33 AM
give make and model of phone please ?
:p

3rdalbum
May 25th, 2010, 11:19 AM
You need a utility called 'padevchooser'. Install it from Synaptic Package Manager, and then run it by pressing Alt-F2 and typing 'padevchooser'.

Start Skype and start the Test Call. The padevchooser icon in your notification area can be left-clicked, I believe, and then you can change the settings so that audio to and from Skype will go from your handset (which is an ordinary audio device).

All other programs will be unaffected, which I imagine is how you want it.

mikewhatever
May 25th, 2010, 11:24 AM
System->references->Sounds. Is the usb device present in the input/output tabs?

simon0404
May 26th, 2010, 05:33 PM
You need a utility called 'padevchooser'. Install it from Synaptic Package Manager, and then run it by pressing Alt-F2 and typing 'padevchooser'.

Start Skype and start the Test Call. The padevchooser icon in your notification area can be left-clicked, I believe, and then you can change the settings so that audio to and from Skype will go from your handset (which is an ordinary audio device).

All other programs will be unaffected, which I imagine is how you want it.

Inside padevchooser there is no option for Skype...... this does briefly flash up for half a second when I load Skype, but disappears again....

The telephone device is found in padevchooser though...

There is no "Sound" option in the preferences menu (I am running 10.04).

The handset does not show a make and model..... just some generic type...

mikewhatever
May 26th, 2010, 06:02 PM
There is no "Sound" option in the preferences menu (I am running 10.04).



Whatever, click the speaker icon instead.

simon0404
May 26th, 2010, 06:06 PM
Inside padevchooser there is no option for Skype...... this does briefly flash up for half a second when I load Skype, but disappears again....

The telephone device is found in padevchooser though...

There is no "Sound" option in the preferences menu (I am running 10.04).

The handset does not show a make and model..... just some generic type...


Nevermind.... I have now managed to set the padevchooser to route the telephone via Skype, using the small logo next to the volume control, and it works fine...

Thanks again for the help,
Simon

astabeno
January 7th, 2012, 05:39 PM
It seems that pdevchoose has been removed in 11.10 is there another way to do this.