View Full Version : [ubuntu] 10.04 does not boot after memory upgrade

May 20th, 2010, 12:34 PM
I have just upgraded to 10.04 and everything was working perfectly, until I upgraded my memory. I cannot boot from live USB / CD - these take me to the initial boot option menu, from which every option (except memory test) results in blinking cursor top left of screen, and cannot type.

Reinstalling my old memory sticks results in the system working fine.

The new memory sticks pass memory tests (bios & ubuntu boot) with no errors whatsoever, and the boot sequence progresses fine until the point where the OS tries to boot.

I am running AMD Athlon 64 3200+, Asus K8V Deluxe m/b. Memory that works is 2x 512mb PC3200 XMS. Memory that doesn't work is 3x 1gb PC2700 ECC.

Any help would be much appreciated, but please provide instructions on the basis that I know nothing, because I no practically very little about linux / ubuntu.

May 20th, 2010, 12:57 PM
Even though the new memory passes the tests, they are not too extensive tests.

I would still try to see what happens with the new memory, but one stick at a time. See if it works and with which stick it doesn't.

On that subject, are you sure you can use 3-channel memory on that board? Or you are not trying to use 3-channel? I am asking because so far you had two modules and presumably you were using dual-channel memory, but now you are trying triple-channel as it seems. Most boards would be dual or triple channel, but not both.

PS. This is an older board. I thought it's newer. Also try with the new sticks, but only two of them, as you had before.

May 31st, 2010, 05:13 PM
Thanks for the suggestion.

I finally got around to trying the first 2 memory sticks (as opposed to all three), and the machine refused to boot, and posted an error message saying the CPU was overclocked.

Given that the bios settings are all set to 'default' at the moment, this suggests a bios setup problem in relation to the memory rather than an ubuntu related problem.

Time for trial and error tweaking in my bios I suspect.....

May 31st, 2010, 05:33 PM
Hm,your new RAM has ECC!Does your mainboard support this?Many boards do not.

BTW,PC 3200 RAM is faster than PC 2700 (FSB 400/333);maybe you run the new RAM with the (too fast) BIOS settings from your old RAM.
Try to reset BIOS with the new RAM plugged in...

June 1st, 2010, 10:31 AM
Yeah the board supports ECC.

I will try manually setting memory speeds for the new RAM.

All of the bios settings are on auto so I was hoping that it would simply pick the appropriate speed for the RAM, but I suspect not.

Unfortunately, the board will only take 3x memory sticks at the lower speed, so I have to replace the 2x 512 sticks of higher speed RAM I already have.

The error I got suggests that the problem is the relationship between CPU settings and memory settings, perhaps the bus speed? Again, I had hoped the auto settings would sort this, but obviously not.

June 1st, 2010, 10:43 AM
have you the latest bios release ?

this MB sould be able to use:

DDR 266 - PC-2100, DDR 266 - PC-2100 ECC Registered, DDR 333 - PC-2700, DDR 333 - PC-2700 ECC Registered, DDR 400 - PC-3200, DDR 400 - PC-3200 ECC Registered

bios settings: try with/without ecc

June 1st, 2010, 01:49 PM
You have not said if you actually tried running Memtest86+ to test the RAM.

I have an HP a530n from 2004 with Asus mobo and the early Athlon64 3200+ (2 GHz, 1024K cache). It has been particular about RAM. Years ago when I bought (2) 512 sticks of PC3200 OCZ RAM on sale at Fry's, it sort of worked, but Memtest86+ came up with errors. OCZ exchanged that for RAM that they guaranteed would work, and it did.

I recently upgraded it to 2 GB with (2) 1 GB sticks of PC3200 PNY RAM and that worked fine. But strangely I could not get the OCZ RAM that worked with my Athlon64 to work in any of our work computers except my Intel 3 GHz with hyperthreading.

One other issue I had with my old Asus mobo is that it does not seem to like the new partition alignment. Fortunately I tried 10.04 on USB drives first and sorted that out. I have to use partman/alignment=cylinder kernel boot parameter (during install, and normal boot). After I got 64-bit 10.04 to boot from a 160 GB USB drive, I installed it to my 200 GB internal drive and that works fine. But strangely that PC will not boot 10.04 from an ext3 filesystem on a 500 GB USB drive (grub rescue says, error: unknown filesystem). Even a regular grub 1.98 prompt from my main hard drive cannot read the ext3 filesystem on the 500 GB drive, although, it can read the ntfs system on that drive. So I must have some Ami BIOS issue somewhere between the 200 GB and 500 GB point.

June 15th, 2010, 07:19 PM
OK - I have updated the BIOS to the most recent stable version, and changed the memory settings to 333mhz in the BIOS.

The BIOS posts successsfully, but I cannot load Ubuntu, either from hard disk or from a USB start-up stick. The USB stick takes me to the initial menu (try without installing, install etc.) but will freeze if try without installing is attempted.

Loading Ubuntu from hard disk results in a screen full of text.

The first attempt ended with a prompt 'initramfs'

The second attempt results in a simple prompt.

Now completely stuck, so any advice would be very gratefully received.

Thanks for the comments so far ):P

June 15th, 2010, 07:39 PM
I just ran Memtest 86+ and the memory sticks are fooked - hopefully some replacements that actually work will fix the 'problem' :rolleyes: