View Full Version : [ubuntu] 10.4: Install disk doesn't find my drive.

May 20th, 2010, 05:19 AM
When I try to install 10.4 on my hard drive, I get all the way to the "Prepare Partitions" menu and there are no disks listed and all button are grayed out.

I am installing on an EVGA X58 motherboard with Intel ICH10 and I have AHCI enabled.

Does Ubuntu support AHCI? Do I need drivers to install?


May 20th, 2010, 05:27 AM
I found a thread while waiting for a reply and it was suggested to run a few commands.

I ran these as suggested:

sudo fdisk -l

sudo blkid


and here are the results:

ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xafd5d703

Device Boot Start End Blocks Id System
/dev/sda1 * 1 13 102400 7 HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2 13 60802 488282112 7 HPFS/NTFS
ubuntu@ubuntu:~$ sudo blkid
/dev/loop0: TYPE="squashfs"
/dev/sda1: LABEL="System Reserved" UUID="9486CF9886CF78EE" TYPE="ntfs"
/dev/sda2: UUID="968ED20D8ED1E631" TYPE="ntfs"
ubuntu@ubuntu:~$ mount
aufs on / type aufs (rw)
none on /proc type proc (rw,noexec,nosuid,nodev)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /dev type devtmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
/dev/sr0 on /cdrom type iso9660 (ro,noatime)
/dev/loop0 on /rofs type squashfs (ro,noatime)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
none on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/ubuntu/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=ubuntu)

May 20th, 2010, 11:32 AM
Has this disk been used in raid before? This usually happens when there is raid metadata remains on the disk.

If you are NOT running raid, you can remove those settings by booting into ubuntu live mode, and in terminal executing:

sudo dmraid -r -E /dev/sda (if your disk is not called /dev/sda, change here)

If that asks you if you want to remove settings, that was your problem. Do it, and the installer will see the disk just fine.

Also, I notice there is no unallocated space on the disk. It's better first to boot windows and shrink the partition you plan to shrink, to make space for ubuntu. Leave the newly created space as unallocated. Boot windows few times to do its disk checks. Then boot with ubuntu cd and install.

In vista and 7 you can use Disk Management for resize. XP does not have the tool for resize.

May 20th, 2010, 07:07 PM
oops, I forgot to post here that I fixed it already. It was the dmraid issue from when this disk was in RAID 0 over a year ago and several OSes ago. I guess formatting or even unallocated the drive doesn't get rid of the RAID info.

I've always used Ubuntu to shrink the drive and auto allocate the disk for me. I do notice it usually uses half the drive and when I installed it on my 1TB drive, it gives way too much to Ubuntu. Maybe next time I'll try my Windows 7 to re-size the disk so I can get the right size I need.