View Full Version : flash drive not detected in lucid

Denny Johnson
May 19th, 2010, 06:14 PM
After an upgrade to Lucid, my 16gb Kingston Data Traveler USB flash drive was not detected.
I have since installed Lucid from a disc, everything seems to work except still no flash drive detected.
I tried the drive on a couple of Windows machines.....it was detected.
The light is on in the flash drive.
No icon appears on the desktop and no sign of it in PLACES/COMPUTER.
Any suggestions?

May 19th, 2010, 06:20 PM

I had the same issue with Ubuntu Lucid upgrade. My flash was not being detected. I googled, found no solution and then reinstalled Lucid (this time fresh install), and my usb drives were detected.

This is no solution but I never found a better one. Actually Ubuntu Lucid is a lot buggy than the previous releases (using Ubuntu since Hardy). Hope these bugs are fixed in the future updates.


Denny Johnson
May 19th, 2010, 06:23 PM
Thanks for the comeback..........I also did a fresh install,........with less success that you.

May 19th, 2010, 06:29 PM
Well. Means I am luckier :p Feels good.

Just a thought, it might be worth testing your PC's usb ports (if already not done). Can't it be a hardware failure?

Denny Johnson
May 19th, 2010, 06:41 PM
mouse dongle works in all 4 usb ports
flash drive works in none

Denny Johnson
May 25th, 2010, 03:55 PM
Tried a new flash drive and it works OK.
Seems it was just coincidence that the old drive went bad around the same time as the 10.04 install.