View Full Version : [ubuntu] 10.04 low graphics mode after update

May 19th, 2010, 06:11 PM
I installed 10.04 fresh on a system, and it worked fine, graphics loaded correctly, X was happy.

After running apt-get update, apt-get dist-upgrade, it still seemed to work, but after a few reboots it goes into "Low Graphics Mode" and refuses to come out.

None of the choices offered actually do anything useful; all I can get is a command prompt.

root@clientdisplay0018:~# service gdm restart
restart: Unknown instance:

doesn't do anything. startx runs, but seems to use fb. My video card is a simple 82G35:

root@clientdisplay0018:~# lspci
00:00.0 Host bridge: Intel Corporation 82G35 Express DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation 82G35 Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation 82G35 Express Integrated Graphics Controller (rev 03)

The same exact hardware works fine in 8.04, and works with 10.04 right after install from the ISO. I'm not sure what is making X think it has to go into failsafe mode; as far as I can tell there are no logs on when it decides to do that.

I reported this similar bug here:


but this is not an NVidia system, it's a simple Intel one. Perhaps the problem is elsewhere?

May 19th, 2010, 06:14 PM

I am having the same problem. Posted it a couple of days ago on forums but still got no answer. Disappointing.....


May 19th, 2010, 06:15 PM
Same problem here, except i updated from 9.10 to 10.04 and i never got to high resolution on 10.04, i had all working fine on 9.10 and older.

May 19th, 2010, 06:34 PM
Same Problem. I'm also getting low-graphics mode error.

I tried

sudo dpkg -reconfigure -phigh xserver.xorg

But didn't worked

using the command startx seems that it initialized KDE but didn't get any results.

May 19th, 2010, 06:37 PM
Is everyone using Intel?

May 19th, 2010, 06:47 PM
I have Ati Radeon, cant remember what its name was but its not so new.

May 19th, 2010, 06:56 PM
I have Ati Radeon, cant remember what its name was but its not so new.

Sorry Otu, I have nvidia and I just reinstalled the driver after the last kernel upgrade broke the video driver I downloaded and installed from their site.

I have no Ati experience.

May 19th, 2010, 06:56 PM
Also seems like ubuntu is failing to recognize my monitor.. i have LG Flatron w1934s and its saying i have Goldstar Company 19", maybe thats nothing as i really do have 19" monitor, well i hope this gets solved fast.

May 19th, 2010, 07:20 PM
I'm using NVIDIA 9500GT.

Thread by me for same problem http://ubuntuforums.org/showthread.php?t=1487915

May 19th, 2010, 09:23 PM
System testing is telling me this:

This display is using the following resolution:

ERROR: xrandr -q should return a single line with '*'

Is this acceptable for your display?

help anyone?

May 19th, 2010, 09:30 PM
Got it fixed myself, went to "configure display settings" and my real monitor was hidden behind this "unknown" monitor, goddamit, well now everythings fine only remaining issue is the weird noise whenever my computer is working on something or i scroll on firefox etc.

October 27th, 2010, 07:32 PM
I'm having a similar problem after upgrading from 8.04 to 10.04. It boots up fine with a resolution of 1280x1024. Then, after running for a while, I get this pop-up window telling me that it is in low-resolution graphics mode. One of the options is to continue running in low-res mode. If one takes that option, the usual, fine, 1280x1024 screen comes back. What is up with this?

Also, it tells me that my monitor is unknown. Neither the monitor nor the graphics card were unknown to 8.04. This is a vanilla Dell Inspiron 530 with a Dell 17" monitor and motherboard-embedded video.

10.04 is seeming more like a retrograde rather than an upgrade.


October 27th, 2010, 08:03 PM
I had similar problems and started a thread here:

It might be the "nouveau" driver that's causing problems. Try un-installing that one.

June 19th, 2011, 09:26 AM
got similar problem. mine card is nvidia mx 440 on ubuntu 10.04 anfter updates is does not boots and gives me error that failed to load nvidia kernel module and running is low res any help