PDA

View Full Version : [ubuntu] Make an downloaded program function



chejose
May 19th, 2010, 02:04 PM
I had been having problems with Thunderbird 3, so decided to install 2.0.0.24. I carefully cleaned out all the 3.0 files. So I downloaded it. Opened it with tar and can see that there is now a Thunderbird folder with all inside of it. But how do I make it run?

If I use "whereis" to locate the file to make it run, it says it is in /etc but i sure can't see it. There is a thunderbird file that seems to be the one in the thunderbird folder, but double clicking and mark "run" does nothing.

So I am lost.

Thanks for help.

Josť

oldos2er
May 19th, 2010, 05:38 PM
There is a ppa for Thunderbird: https://help.ubuntu.com/community/ThunderbirdNewVersion

Also Ubuntuzilla: http://sourceforge.net/apps/mediawiki/ubuntuzilla/index.php?title=Main_Page

chejose
May 19th, 2010, 07:08 PM
Thanks... but it is aimed at new versions. I cannot run apt-get because it tries to install the version 3, while I want to install the version 2.

The file came as a .tar.gz file. I opened it using tar and it formed folders with what I assume is the program. The problem is how to make it run.

Josť

ankit singh
May 19th, 2010, 08:28 PM
Most of the application which are installed from source code are by running this commands


./configure(which checks to see if you have the dependencies to allow it to work, if not, you’ll have to manually install them)

make(actually compiles the source code)

sudo make install(actually installs the now compiled source code)

clean install(cleans the temp files used to compile the source code)


while you’re in the folder that has the source files. It’s just a simple CD (change directory) command to jump into the folder that you uncompressed your saved source file to. If you’re using Ubuntu and compiling files from source for the first time, you have to install the build-essentials, run it from terminal:


sudo apt-get build-essential

ankit singh
May 19th, 2010, 08:34 PM
oh i almost forgot to say that this method will not work for everything, so when you download a package, make sure to read the ‘README’ or ‘INSTALL’ file, which should walk you though it step by step. Always follow the provided documentation first, if you can’t get it working from using that, then this is a secondary solution that should work for you fine.

is there any reason why u want to go to previous version?

wojox
May 19th, 2010, 08:40 PM
It should be built already. Open a terminal and run:


thunderbird

That should run it. Then you can move it to your /opt directory and create a link in your menu or panel.

chejose
May 19th, 2010, 10:14 PM
Thanks for all the feedback. I'll have to work on it for a while to see what I can do. I already tried running "thuderbird" in the terminal but it says that it is not installed yet.

I am going to try to shift to an older version since I have been struggling with the lastest version on more than one forum for days to solve a problem, but nothing. Since version 2 worked well in my earlier installation of Ubuntu (9.04) I hope this earlier version will work now.

Again, thanks.

Josť

oldos2er
May 20th, 2010, 12:58 AM
Looks like I gave you the wrong URL. Try https://help.ubuntu.com/community/Thunderbird#Thunderbird%202.0