View Full Version : [ubuntu] No Sound in Alienware Area-51 M15x

May 14th, 2010, 09:25 PM
Hello All,
I Most recently switched to the world of Ubuntu after a friend of mine was telling me how amazing it is, and i do completly agree and love it. Though i have a few questions and need a little help :)
1. My speakers do not work, my headphones do however work when i plug them in.
2. I need to run Visual Studio for my Programing class, tried installing with Wine...gave me a error message :/ Or is there a another option?
3. Is there a way to get the color changing program for my lit keyboard.

This is my system here:


May 14th, 2010, 10:05 PM
1) Click the Volume icon and then click preferences and make sure Front PCM etc... Aren't Muted.

2) Visual Studio I'm not familiar with is it for coding in Visual Basic? You might need to dual-boot or possibly load windows in a VirtualBox for it.

If I remember correctly Dell bought out Alienware you could check there forums about your keyboard because I honestly Don't know. (Dell has pretty decent Linux support for an OEM)

May 15th, 2010, 04:26 AM
Can you post the output of these terminal commands for me please:

uname -a
aplay -l
cat /proc/asound/version
head -n 1 /proc/asound/card*/codec#*
Please post text output using code tags. Also helpful is the make/model of your PC/Laptop.

May 15th, 2010, 05:36 AM
Thank you both, was able to fix it from dells fourms. THanks much :D

May 16th, 2010, 06:14 PM
Thank you both, was able to fix it from dells fourms. THanks much :D

Awesome. Could you post the fix, or a link to it, and mark the thread as solved using 'Thread Tools' up top please?