View Full Version : [ubuntu] No sound on gtk-recordMyDesktop

May 13th, 2010, 10:54 PM
I've just installed gtk-recordMyDesktop (RMD from henceforth) on a fresh-install of UBuntu 10.04. There is no sound in the file that RMD creates.

The sound that I wish to capture is the sound from a flash video playing on a webpage.

I tried the advice given at http://ubuntuforums.org/showthread.php?t=1428157, but to no avail.

Please help.

May 23rd, 2010, 03:14 PM
same here,i think this is an unsolvable problem :-(

Solved thanks to the link: http://fostergrant.ubuntuforums.org/showthread.php?t=1328176&page=3

1) Install pulse mixer applet;
2) Open alsamixer and set everything up (except the microphone), including capture;
3) Start the music;
4) Open gtk-recordMyDesktop and in sound tab insert "pulse" in place of "DEFAULT";
5) Start recording;
6) Launch pulse mixer;
7) In the recording tab choose "Monitor analog stereo of Internal Audio" in place of "analog stereo of Internal Audio";
8) enjoy!;

May 28th, 2010, 07:09 AM
Can experienced Linux users confirm whether einstenian's plan is good or not? Thanks.

January 3rd, 2011, 05:26 AM
I know this thread is half a year old, but I just wanted to confirm that the above solution did work for me! Thanks! Just to clear up any confusion, the "pulse mixer applet" is the Pulse Audio Volume Control, which can be found under the name pavucontrol.