PDA

View Full Version : mount.cifs no longer permitted



radiognome
May 11th, 2010, 09:16 AM
I used to have some samba-shares in fstab with a credentials-file and such, so I could mount and unmount them without 'sudo' in cron-jobs, scripts etc...

This worked for years until I upgraded to 10.4 (skipped 9.10)
I now get:
mount error(1): Operation not permitted

(and a full partition on my server because all automatic backups were written at the mount-point in the directorystructure since the upgrade)

When I 'sudo' the mount, it works, but hey, that was not what I wanted.

Apart from this, upgrading to 10.04 LTS 64-bit worked like a charm.

When I get this issue solved, I would mark 10.04 a :KS:KS:KS:KS:KS

mehturt
May 12th, 2010, 08:44 AM
try:
sudo chmod +s `which mount.cifs`
I am not sure whether this is the proper solution.
EDIT: I just found a bug about this.. https://bugs.launchpad.net/ubuntu/+source/samba/+bug/563805

radiognome
May 12th, 2010, 05:29 PM
Thanks mehturt,

Silly I didn't find this launchpad bugentry myself. Probably used all 'just not the propper mix of searchwords' before giving up.

Will try this as soon as I get back at the office on friday. Not having proper automated database-dumps starts getting itchy :)

GrokIt
May 18th, 2010, 07:30 PM
I had the same problem and I fixed it with these 2 commands


sudo chmod +s /sbin/mount.cifs
sudo chmod +s /sbin/umount.cifs
Works just like before now.

radiognome
May 18th, 2010, 08:13 PM
Thanks GrokIt

I used the same commands, and since then forgot about it.

Funny... Don't know why this set-bit suddenly causes trouble sincd 10.04 and don't know why people are against it (see bug-report). Hope this gets settled proper and for all.

GrokIt
May 19th, 2010, 12:40 AM
Yeah it looks like a security problem from what I see. I hope it's just something that can be fixed. This will drive new users batty.
Someone on the Kubuntu list is asking almost the same thing, except he has a gui problem. It's nice to able to spread the help.

Ganton
May 26th, 2010, 07:04 PM
All was done on purpose to avoid security attacks.

Instead of changing the "setuid bit"... use first "sudo visudo" and later "sudo".

More information in:
https://bugs.launchpad.net/ubuntu/+source/samba/+bug/563805/comments/10

lotharmat
August 27th, 2010, 11:23 AM
I had the same problem and I fixed it with these 2 commands


sudo chmod +s /sbin/mount.cifs
sudo chmod +s /sbin/umount.cifs
Works just like before now.

Thanks for this! - It was driving me insane

Using..

sudo mount.cifs

was leaving me unable to copy files into the mounted share! (unless I used the terminal and prefixed the mv command with sudo too.

war59312
February 10th, 2013, 05:41 PM
Not working for me:


Couldn't open /etc/fstab for reading!

Whoops, just realized this thread is really old... whoops.. cant delete it seems..

sorry..

ok i see it wont be fixed, ever. for good reasons.. oh well

see: https://bugs.launchpad.net/ubuntu/+source/samba/+bug/563805

oldos2er
February 10th, 2013, 08:57 PM
Old thread closed.