View Full Version : [ubuntu] 10.04 Random init script startup problems

May 9th, 2010, 11:20 AM
Starting to pull my hair out now.

I've installed a clean 10.04 server (64 bit) on my HP ML115 server along with MythTV and a minimal GUI (Gnome)

Now sometimes when I start up, I get no Apache2 running along with some other services. This is very random - it can happen on a cold boot, warm reboot but it still happens every now and again.

I turned my server on this morning - no Apache although I could SSH in, left it for half an hour - still no Apache. Rebooted, everything working.

Now I've got some snippets from logs when it was and wasn't working, the main differences are as below:

This was when it wasn't working:

May 9 08:42:25 pbhp ntpd[966]: frequency initialized -140.646 PPM from /var/lib/ntp/ntp.drift
May 9 08:42:26 pbhp init: Failed to spawn rc main process: unable to open console: Input/output error

The line "Failed to spawn rc main process:" was missing however on the boot that worked which makes me think this might have something to do with it.

Now the only other thing thats niggling me is this always seems to happen around the ntp / ntpd lines - I might be grasping at straws but would changing the system time halfway through a boot confuse upstart / scripts relying on timing ?

I've been trying to get this server "perfect" since the release of 10.04 and have re-installed many many times with the same problem every time - seemingly random startup script problems.

To me, it looks very similar (if not identical) to this problem here :


Thanks for any help


May 11th, 2010, 02:36 AM
I am not computer savey enough to describe my problem in any detail, but I too am having start up problems. When I boot normally, the screne just goes black. Dead.

I can run the computer in the failsafe graphics mode that one can select in the menu by pushing escape. Will running the computer in this mode hurt it?

May 11th, 2010, 10:54 AM
I don't know if I've accidentally uncovered a solution but I spotted a post saying if you removed the "quiet splash" and replace with "nomodeset" then it might help.

I've done this and not had any more problems.

It may be coincidence but my machine has behaved for the past couple of days. The biggest problem is that this issue is pretty random so it may have nothing to do with it.

May 15th, 2010, 11:10 AM

I'm having the same issues mate! I upgraded and installed Server 10.04 on my file server about a week ago and some startups aint happening! Webmin fails to start as does apache2! I also use a utility called tleds (i like my my keyboard lights to flash for network traffic!) and that doesn't start either!

I have to SSH into the box to start them via init scripts!

I was wondering what could be affecting a selection of daemons!
Some please help! i dont wanna have to backup my confs and reinstall 9.10

May 15th, 2010, 11:12 AM
Mine has happened from a 100% clean install so its not an upgrade thing.

I'm keeping my eyes on it all and will post back (as I hope you will) if and when I spot a solution.

For the past 3 or 4 days though its been fine but I know it will randomly fail to start at some point.

June 18th, 2010, 09:09 AM

You should try workarround as posted in


I had similar problem with a clean install of Ubuntu 10.04 and this workarround solved it.
I only applied

From comment #54
Comment out "console output" in all /etc/init/*.conf files that
have it.

From comment #73
Add "started rsyslog" to the "start on" stanza in /etc/init/rc-sysinit.conf:
start on ( filesystem
and started rsyslog
and net-device-up IFACE=lo


June 18th, 2010, 09:35 AM
As an update, a few days ago I commented out all of the "console output" on my revo and HP server in the /etc/init files and haven't had a failed boot since.