View Full Version : [ubuntu] 10.04 black screen white stripes

May 8th, 2010, 03:34 PM
I recently downloaded Ubuntu 10.04, works perfectly on my laptop but ran into problems with my desktop. The Live CD doesn't start. I get the bootloader where you can select the language etc but when I choose to start the Live CD I get a black screen with white strips
picture: http://users.telenet.be/smggm/ubu.jpg
This stays like that until I use the reset button.

I already tried to install it using the text based installer. That works (I can install Ubuntu) but I get the same problems when I try to boot the system in GUI.
I also read something about force VESA but that didn't work either.
Also someone solved his problem by installing a previous version of Ubuntu and then upgraded to the most recent. That didn't work for me because I just got the same problem (black screen white stripes) with my old Ubuntu 9.04 cd.

I'm almost certain it has something to do with my GPU, but I don't have one signal clue where to start now. I have a ATI Radeon 2900GT, Intel E670 2.66GHz and 2GB DDR2 RAM.

I hope someone can help me with this problem. I really want to force me a bit to work with Ubuntu but this problem isn't really helping me switching.

Thx in advanced ;)

May 8th, 2010, 09:01 PM
OK I succeeded in installing Ubuntu with the GUI. I installed Ubuntu again with the text based installer and the I used the graphics failsafe option. In grapics failsafe I installed the restricted ATI drivers but then some new problems pop up... I rebooted and things looked good but I see a AMD watermark that displays 'Unsupported hardware' but other then that the drivers work perfectly (I wonder why they put that message there in the first place if it works, but hey that's just me). So I downloaded the restricted drivers from the AMD's site (catalyst version 10.04), removed the other drivers and rebooted in failsafe to install the catalyst 10.04 drivers.

Everything looked perfect. I could start in 'normal' mode and the watermark was gone. Only problem is that the resolution was a bit low so I wanted to change it... NOT. There is now higher resolution available then 1152x864. I then wanted to check that ATI control panel and got the message:

There was a problem initializing catalyst control center Linux edition
No ATI graphics drivers is installed, or the ATI driver is not function properly.
Please install the ATI drivers appropriate for you ATI hardware, or configure using aticonfig
When trying to use the aticonfig (/usr/bin/aticonfig) I get the lovely message: No supported adapters detected

So to give a quick overview:
Restricted ATI drivers that Ubuntu suggests: AMD watermark Unsupported hardware
Restricted ATI drivers from AMD say No supported adapters detected

Why can't this sh$t just work?
Meanwhile I'll be going back to the worlds best operating system: WINDOWS (it's the only one that seems to work decently)

Any feedback or suggestions would be great ;)