View Full Version : [SOLVED] 10.04 Was Stuck on Purple Boot Screen

May 7th, 2010, 08:31 PM

I just thought I'd share some of our experiences with the world concerning Lucid Lynx. My wife decided that last night at 2200 (hours before bed mind you), that she was going to upgrade her new laptop to 10.04. Well, that seemed to be an ok idea, except for the fact that it wasn't. I just want to let all the neophytes (myself included) that if you're unsure about your hardware AT ALL, its a good idea to attempt to run any serious linux revision from a Live CD first before upgrading. This gives you an opportunity to discover, "Oh wait, my graphics card isn't that well supported" or "Crap, where did my wireless card go", before it becomes an issue.

We weren't so fore thinking.

She just hits the button in the upgrade manager to get 10.04, and we were off. Everything seemed to install just fine, and about half an hour later we were rebooting into 10.04. I wasn't a fan of the annoying purple screen that appears at boot, especially after it stuck there for five plus minutes. Yeah, we were victims of the infamous "stuck at purple boot screen" phenomena. Not fun, especially since my wife is bummed that her new lappy is dead in the water after working just fine half an hour ago. So together we hit up the forums, and we had some saw good advice. Here's what we did to fix it (a lot of this is info already posted, except one key item):

lappy: Acer Aspire 7740
OS: Ubuntu Lucid Lynx 10.04
Upgrade from 9.10
Stuck at purple boot screen

Seemed the issue was a graphics driver problem at first. We attempted to boot with the nomodeset option several times, however this just turned the screen white at boot. All of the adive we had read stated that we needed to get to a console however, so we attempted to boot into recovery mode from the GRUB menu. This would have worked fine, except that ubuntu seems to require a password for root when using this option, and my wife had never turned on the root account. Her user password didn't work, and we were stuck again. (Side note, I'm not Ubuntu junkie yet, but I'm sure when I am that this sort of hold up will not be an issue).

Anyway, we were also advised to boot from a Karmic Koala disk, and access the system to fix it that way. But her lappy just would not boot from the disk either. I was about to dig out a Knoppix disk, but she bumped into an option to boot into a safe graphical environment from the recovery kernel option in GRUB. Blam we where in with no apparent issues. We found that xorg.conf was missing, but there was a xorg.conf.failsafe that we were able to copy to xorg.conf, and bingo. Lappy boots 10.04 without issue, and it seems 10.04 even fixed some of the video playback issues we were having before.

So .. FYI ... if you are having troubles booting 10.04, try holding shift during boot to get to the GRUB menu, select the recovery console, and boot using the safe graphics mode. Just another option is you can't seem to get anything else to work.