View Full Version : [all variants] Desktop Launchers in Lucid No longer work

May 5th, 2010, 12:03 AM
There must be something turned on in the security settings keeping Desktop Launchers from working.

I have verified that the launchers have execute bit turned on in the permissions, yet when try to start one, I get an alert window saying this is an Untrusted application launcher.

How do I disable this feature, or in the alternative, make them trusted?

Thanks in advance!

May 5th, 2010, 03:42 PM

Any ideas?

May 6th, 2010, 11:17 PM
bump again..

Any ideas?!

May 26th, 2010, 10:42 AM
Thread a bit old but in case anyone else stumbles upon it:

Up until 10.04, ubuntu used to warn you it was untrusted but give you a button to "mark as trusted" and all would be well again.

Two options now:

If you don't want to mark it as trusted but just temporarily run it, right-click on the *****.desktop launcher and select run as administrator.

If you want it trusted, show its proper icon, etc.: right click on it and select properties. On the permissions tab of the menu box that appears, tick "Allow executing file as program".... and all is well again.

June 22nd, 2010, 07:47 AM
Thanks, the first option works and is my workaround for the while. The second doesnt, though. The behaviour is neither changed by chmodding +x, nor by setting the tick at "allow execution" in permissions. Might be a bug...