PDA

View Full Version : [SOLVED] cant upgrade system



nerdy_kid
May 3rd, 2010, 01:45 PM
hey all, i reported a bug at https://bugs.launchpad.net/ubuntu/+source/packagekit/+bug/573893 but nothings happening, so i thought maybe you guys could help me fix it. basicy i hit the refresh button in kpackagekit's update modual and after it downloads the respitory stuff i get an error:



Error Type:
Error Value: coercing to Unicode: need string or buffer, exceptions.SystemError found
File : /usr/share/PackageKit/helpers/apt/aptBackend.py, line 2216, in
main()
File : /usr/share/PackageKit/helpers/apt/aptBackend.py, line 2213, in main
run(args, options.single)
File : /usr/share/PackageKit/helpers/apt/aptBackend.py, line 2175, in run
backend.dispatcher(args)
File : /usr/lib/python2.6/dist-packages/packagekit/backend.py, line 699, in dispatcher
self.dispatch_command(args[0], args[1:])
File : /usr/lib/python2.6/dist-packages/packagekit/backend.py, line 606, in dispatch_command
self.refresh_cache(force)
File : /usr/share/PackageKit/helpers/apt/aptBackend.py, line 202, in _locked_cache
func(*args, **kwargs)
File : /usr/share/PackageKit/helpers/apt/aptBackend.py, line 1498, in refresh_cache
format_string(error.message))
File : /usr/lib/python2.6/dist-packages/packagekit/backend.py, line 723, in format_string
txt = unicode(text, encoding, errors='replace')


this is a lucid thing cause the same kde version (4.4.2) was working fine in karmic.

is there any way that i can fix this? thanks :)

rockinrobstar
May 3rd, 2010, 05:43 PM
I'm getting the same problem.

Are you trying to use a proxy that requires authentication by any chance ?

nerdy_kid
May 4th, 2010, 12:41 PM
I'm getting the same problem.

Are you trying to use a proxy that requires authentication by any chance ?

nope :(

nerdy_kid
May 4th, 2010, 01:30 PM
ok fixed it, had a bad entry in my sources.list

jbruni
May 10th, 2010, 10:19 PM
In fact, there was a bug in KPackageKit, recently fixed:

https://bugs.launchpad.net/ubuntu/+source/packagekit/+bug/546607