View Full Version : [SOLVED] Grub 2 won't boot windows 7 after upgrade

May 2nd, 2010, 08:27 PM
Hi, when I upgraded my xubuntu from 9.10 to 10.04 I chose to keep my old grub (legacy). This went almost well... Both Windows 7 and Xubuntu booted, but xubuntu used a lot more time booting now than before.

I figured that maybe upgrading grub to grub2 would help. Now the new grub-menu appears with both xububtu and windows 7, but nothing happens when I try to boot windows 7.

Do anyone know what might be wrong, or what to do?

May 2nd, 2010, 08:27 PM
Try this (http://sourceforge.net/apps/mediawiki/bootinfoscript/index.php?title=Boot_Problems:Boot_Sector)

Paul T.
May 2nd, 2010, 08:35 PM
You might want to read this post, seems to be a known issue:


May 2nd, 2010, 11:48 PM
Thanks for the quick answers!

I tried nitstorm's link, which, after trying out "testdisk", advised me to use the windows installation disk and fix the mbr/boot from there. Now the pc boots directly to the windows recovery partition. :(

Then I have tried to reinstall grub from a live-usb. Where do the changes I do from live-mode apply?

"find /boot/grub/stage1" gives me: "Error 15: File not found"

Any ideas? :)

May 3rd, 2010, 12:37 AM
:) you guys don't have to bother with this problem anymore. I have struggled with this for several days now and learned a lot. But being a new linux-user, I want a fresh start. So I'm reinstalling linux and hoping for better "luck."