View Full Version : [SOLVED] USB not mounting in 10.04

May 2nd, 2010, 02:17 AM
I have recently installed Ubuntu 10.04 and am completely happy with its performance, however i cannot get any USB device to mount, and tips would be helpful. Running a Dell Studio 1555

May 2nd, 2010, 02:37 AM
Are these USB devices formatted as NTFS or as fat32? (by default most USB flash drives are formatted to fat32).

Also can you plug one in, wait 30 seconds, and then post the output of this command:


Jon Monreal
May 2nd, 2010, 02:39 AM

Could you try going to a terminal, typing

ls -l /dev/disk/by-id/*usb*
and posting the output here.


The Thunder Chimp
May 2nd, 2010, 02:44 AM
Is the "usbmount" package installed in Synaptic. I used to have that problem in Karmic, and that was the solution.

November 9th, 2011, 04:49 PM
Amazing, I run Lucid and just checked in Synaptic if usbmount was installed: it wasn't!
I suppose Synaptic will have removed the usbmount package last time I uninstalled something, although I can't remember when this would have happened...
Thanks a lot for help folks!!!

Best vibes from Madrid 8-)