PDA

View Full Version : [SOLVED] 10.04 won't boot



randomlogic
May 1st, 2010, 07:30 PM
I just upgraded a desktop and a laptop from 9.10 to 10.04. The Desktop upgrade went flawlessly and is being used to write this.

The laptop upgrade failed on reboot. Ubuntu doesn't get past the splash screen. I downloaded the install CD and tried booting from that. Same results. Does anyone have any suggestions on how I can recover from this?

I'll revert to 9.10 on the laptop if I must, but I am hoping that will be unnecessary. The laptop is a 5 year-old Gateway with a new hard drive and has been running Ubuntu for 3 years.

Thanks in advance for any help.

kutagh
May 1st, 2010, 08:23 PM
Sounds similar to me, 6 years old Toshiba Satellite A10.
Are you using intel integrated graphics GMA something too?

Using the Live CD version of Xubuntu 10.04, I got after choosing "Install Xubuntu" or "Try Xubuntu without installing" a blank screen, nothing happens, absolutely stuck as far as I can see. Using the alternate CD worked, it installed flawlessy... After rebooting, it will go to the logo, and then clear the screen.... and stay that way. Forever....

Managed to get recovery mode working, used 'boot failsafe graphics' and it booted into Xubuntu. I got the nagging feeling it is related to graphics.

randomlogic
May 2nd, 2010, 12:45 PM
I suspect the graphics myself. I was just caught off guard that it worked in one version, but not in the next - especially since this is an LTS release.

Anyway, now that I have some free time, I'm looking into other posts for a clue. I've got the laptop up and running via the 9.10 install disk. And I'll go back to that version if I must. But I'm confident that I will find a solution.

randomlogic
May 2nd, 2010, 03:38 PM
I managed to solve this problem. It seems to stem from kernel 2.6.32-21

Using 10.04 boot CD
on the boot screen, press F6, then ESC.
At the end of the command line, add the following:

i915.modeset=0 xforcevesa

(I found this in another posting.)

During normal startup, hold down ESC (if you are using Grub), or SHIFT (if you are using Grub2). I'm using Grub2.

When I brought up the menu, I saw entries for:
Linux 2.6.32-21
Linux 2.6.31-21

2.6.32-21 was the default. I selected 2.6.31-21 and successfully booted.

Next, I installed the "startupmanager" package

After the installation, I went to the System|Administer menu and ran Startup-Manager

I made 2.6.31-21 my default and closed the program (which saved my settings). I rebooted, and started typing this reply.

The fact that I was able to boot from the older kernel leads me to believe that the problem is in the default kernel that 10.04 installs/uses.

I hope this helps others who have been struggling with the same issue.

randomlogic
May 16th, 2010, 06:03 PM
Well, after kernel 2.6.32-22 was released, I tried again and my original problem was back. So I did some more searching and came across the following: https://wiki.ubuntu.com/X/Bugs/Lucidi8xxFreezes

This was exactly the problem I was having and the first suggested workaround fixed my problem.

I hope this helps others who might still be struggling with this problem.:)