PDA

View Full Version : [ubuntu] Lucid upgrade breaks dual monitor set up



steveu6
May 1st, 2010, 02:59 PM
When Karmic came along, I upgraded and it was possible for the first time to get a dual monitor display working using only the GUI apps supplied. (I think I used screen resolution) It worked out of the box and took no time whatsoever.

I had a dual monitor set up working with 2 1024 x 768 monitors, with a desktop spanning both, and a background picture doing the same.

The Lucid update has just spectacularly broken this, along with a large number of desktop type changes that were unwanted.

The version of Ubuntu was the usual vanilla, but with enough K stuff installed to make K3b work. The card is a Radeon 9250SE.

Has anyone any ideas for an easy solution?


Give up and re-install Karmic?
Wait for some sort of upgrade to allow either Monitors or Multiple Screens to work - the option to remove cloning is greyed out in one and unticking clone in the other does nothing?
Try some other distro?


Does anyone know of a decision to remove any functionality from Lucid that existed in Karmic? Is there any useful background to this that is perhaps not obvious?

I'm wondering why when an upgrade will seriously break something that no warning is given?

I'd advise anyone with dual monitors and this card to either back up before upgrading or hold off until the same card works elsewhere. Yes, I know I should have backed up, but then this was the trial for the laptop running Karmic which I will now not upgrade. Thankfully this is the PC that I check upgrades on before doing them on the more oft used laptop.

notquitemichael
May 1st, 2010, 03:11 PM
I don't know if your using third party/restricted drivers, but I'm using an nvidia card and my dual-screen setup works now, but it needed some help with the configuration.

I've found that everytime I've upgraded I've had to restore/fiddle with the xorg.conf file.

WinterRain
May 1st, 2010, 04:44 PM
Give up and re-install Karmic?


I would clean install Lucid. Upgrades are iffy at best to begin with. My dual monitor set up is fine in lucid.

Niksko
May 1st, 2010, 05:31 PM
My dual monitors are broken as well under Lucid. Both of my screens are detected but only the one that is connected directly to the VGA output of the card displays anything. The other screen which is connected via a DVI->VGA adapter doesn't work

Ideas?

-Nik

steveu6
May 1st, 2010, 06:51 PM
I don't know if your using third party/restricted drivers, but I'm using an nvidia card and my dual-screen setup works now, but it needed some help with the configuration.

I've found that everytime I've upgraded I've had to restore/fiddle with the xorg.conf file.

Not using 3rd party or restricted drivers.

AFAIK the xorg.conf file is no longer used - the one from the upgrade to Karmic has only a few lines it to define the whole desktop - 2048 x 768.

Seeing as I don't know for sure that I'll get a working dual monitor set with Lucid a karmic re-install is the way to go?

pertti
May 1st, 2010, 07:09 PM
I'm having a similar problem with my Dell 6400 laptop, which has an ATI x1400 video card. I installed Lucid from scratch (keeping the same home folder I had for Karmic), and when I tried to configure the second monitor I got a terrible image with waves all over the second monitor.

I am using the open source ATI drivers. In fact, the restricted drivers managers doesn't let me chose the driver from ATI for my card. The resolution of the laptop screen is 1680x1050 and the resolution of the external monitor is 1920x1080. With Karmic I had a small xorg.conf file, with just the resolution of the whole setup (3600x1080). With Lucid I have no xorg.conf file at all (I understand they were going to be unnecessary at some point), but I also tried using my old xorg.conf file to no avail.

I have found a similar report (same laptop, different external monitor resolution) in the Lucid development thread (http://ubuntuforums.org/showthread.php?t=1451072), but there were no answers.

Does anybody have a clue what could be wrong here? Should I try with the closed source driver from ATI? Is it still available?

Thanks in advance

end3rkid
May 2nd, 2010, 09:25 AM
I'm having some problems with video drivers on Lucid too :(.

shah_vm
May 2nd, 2010, 07:08 PM
i am also having display issue. When i play movie on external display thru vga which is set to 1920x1080 movie is truncated at half screen. it does not show in the full screen. however i can see the window covering entire screen. I can see all the windows in full screen only video is truncated to half screen. I on ati mobility x300 graphics card. I have not installed any graphics drivers yet.

anyone having same issue?

ropic
May 2nd, 2010, 10:20 PM
I have exactly the same problem using a Dell Inspiron 6400, any solution ?

SergeiFranco
May 3rd, 2010, 12:53 AM
I have same video card and does exactly same.
I tried to set it to different refresh rates without any effect.
It looks like bad VHS tape. Or poor TV reception.

Right now dual screen is completely unusable.

The card is X1400 Mobility (piece of crap, but laptop comes with it and there is nothing I can do to change that).

This is how I set resolution "xrandr --output VGA-0 --off && xrandr --output VGA-0 --mode 1280x1024 -r 60 --right-of LVDS".
I also tried KDE system settings: same effect (although I am pleased that KDE now has "working" display settings).

Has some one submitted a bug?

SergeiFranco
May 3rd, 2010, 12:57 AM
Here it is:
https://answers.launchpad.net/ubuntu/+question/108939

SergeiFranco
May 3rd, 2010, 01:33 AM
And another one
https://bugs.launchpad.net/ubuntu/+bug/573290

pertti
May 3rd, 2010, 01:57 AM
It seems that is a problem that affects many ATI cards. I found a (partial) solution here: https://bugs.launchpad.net/ubuntu/lucid/+source/linux/+bug/545096. Try using "nomodeset" in the boot command in GRUB (see comment https://bugs.launchpad.net/ubuntu/lucid/+source/linux/+bug/545096/comments/5). With this flag I get my dual monitor setup to work again. However, full screen video (or enlarged up to a certain size) looks weird.

SergeiFranco
May 3rd, 2010, 02:02 AM
This drives me insane, it also looks like the working screen is driven less than 60Hz as I can see it flickering (this is Laptop LCD screen I am talking about).
How does one switch video driver from crappy ati-xorg one to vesa, since there is no xorg.conf anymore?

SergeiFranco
May 3rd, 2010, 02:31 AM
It seems that is a problem that affects many ATI cards. I found a (partial) solution here: https://bugs.launchpad.net/ubuntu/lucid/+source/linux/+bug/545096. Try using "nomodeset" in the boot command in GRUB (see comment https://bugs.launchpad.net/ubuntu/lucid/+source/linux/+bug/545096/comments/5). With this flag I get my dual monitor setup to work again. However, full screen video (or enlarged up to a certain size) looks weird.

Thanks, that has fixed my issue. At this stage I don't care about full screen video.
I made a big mistake jumping on "upgrade to 10.04" band wagon. Should have waited 6 months.

crankenstein
May 3rd, 2010, 02:42 AM
Hi All

same problem with a dell 6400 with an ATI x1400 video card. Cant output to TV (really blurry) and when i try and play AVI's in full screen it starts dropping frames (really Jerky)

Switched back to Karmic all all sweet. Not sure on what happened with the upgrade :(

WinterRain
May 3rd, 2010, 02:58 AM
Should I try with the closed source driver from ATI? Is it still available?


Just go to the ATI (AMD) website and download the driver.

SergeiFranco
May 3rd, 2010, 03:17 AM
Just go to the ATI (AMD) website and download the driver.

There is no driver for X1400 series. It is "obsolete".

EDIT: what I meant to say the driver on website does not work with ubuntu due to some sort of version mismatch (last time I tried to go that path).

iblazev
May 3rd, 2010, 07:17 PM
Same thing here. ATI x1300 and opensource drivers that came with Lucid don't work very well when it comes to dual display.
Unfortunately ATI restricted drivers don't work on Lucid and I'm not that savvy with configuring kernel or restricted drivers to make it work.

It would be nice if anyone with more knowledge would give some points on what to try at least

janneman37
May 6th, 2010, 02:53 PM
Hi,

I have a laptop fujitsu siemens with ATI X1400 card and after a few minutes my laptop screen is flashing/flickering... ubuntu 10.04. i have the open source driver.

crackham
May 10th, 2010, 06:16 PM
Same thing here, worked perfectly until the "upgrade" to 10.04.
Older ATI x1400 on a HP laptop.

Sidenote,.. upgrade also nuked my wireless.. thanks!!

ppyo
May 13th, 2010, 12:07 PM
I have a slightly different problem with my Asus 1000HA netbook and an external Acer 18" monitor with the Lucid upgrade. My monitor configuration keeping the Asus screen off and the Acer on as sole monitor worked like a charm on Karmic, while after the upgrade the configuration won't stay set, it always reverts on boot to the dual monitor, extended desktop setting. When I set the configuration back to one monitor, it works, but if I play a video, it will turn back again to the dual monitor setting.
This is very annoying.
Other than this, Lucid has been great.

petersk
June 14th, 2010, 01:17 AM
You know, I have an X1650 and had the same problem with ATI: their proprietary drivers are great, but don't stay up to date with our "older" cards. The latest I can find that supports my card is the 9.3 and that doesn't support lucid. So... I guess I'm going for the FOSS driver; who knows how dual monitor support on that will turn out. I only want to do development on my linux machine and possible watch some vids/multimedia.
That being said, I'm considering buying a gaming machine and although the ATI cards seem to be stomping nVidia right now, I think I'll buy one with an nVidia driver just to send my little message to ATI that their lack of support for "older" cards is unacceptable.

steveu6
June 16th, 2010, 12:04 AM
Try using "nomodeset" in the boot command in GRUB (see comment https://bugs.launchpad.net/ubuntu/lucid/+source/linux/+bug/545096/comments/5). With this flag I get my dual monitor setup to work again.

Thank you very much Sir!

With this one word of code my dual monitor set up is now unhosed. I have the dual monitors back again!!!!!

I'm very pleased. :cool::cool:

I gksudo'ed gedit to alter /boot/grub/menu.lst, added the one word needed at the end of the line marked out and I was away.