PDA

View Full Version : [ubuntu] 10.04 /dev/md0 doesn't exist when grub2 tries to access it



mathuin
May 1st, 2010, 07:08 AM
I have installed Lucid Lynx more than a dozen times in the past thirty hours and I've almost got it working with RAID. The current problem is with /dev/md0 not existing when grub2 tries to access it.

When I boot from the alternate CD in rescue mode, Ubuntu sees /dev/md0 as a software RAID array and I can access the files accordingly. When I boot from the grub2 bootloader, it sits for a while before spitting out "Gave up waiting for root device" and tossing me into the initramfs shell where I can see that /dev/md0 doesn't (yet) exist.

What can I change within grub2's configuration to inspire it to start /dev/md0 before trying to mount it?

Thanks in advance!

Xiphias256
May 1st, 2010, 09:17 AM
I also want to know how to fix grub2!!
I've been ](*,) since Ubuntu 9.10 with this issue. An upgrade to 10.04 didn't solve it either. :(

I was able to make the first initrd.img work, and have been stuck with it since. Lucky for me that I took a copy of the kernel that worked. Because Ubuntu figured it should clean my /boot area, and removed all old kernels.

Now my server thinks it needs to upgrade to 10.04, since I'm running a kernel from 9.10. :-s

eombah
May 2nd, 2010, 12:52 AM
Exactly the same problem here.

-Bart

hatalar205
May 2nd, 2010, 12:57 AM
I have the same problem. As fas as I know it is already reported as a bug and it will be solved soon. Just be patient.
By the way when I first boot it just waits for 6 or 7 minutes and then it boots normally. And after everyboot it boots faster.

eombah
May 2nd, 2010, 01:04 AM
Would you know the link to that bug?

Blue Duck
May 19th, 2010, 09:51 PM
Same issue. Any workaround?

I've just gone a step forward: adding 'raid1' (without quotes) to the /etc/initramfs-tools/modules file, and then:

$ sudo update-initramfs -u -k $(uname -r)
have made the initramfs shell see my mdX devices...

But I still can't boot on it :(

Blue Duck

eombah
May 20th, 2010, 06:22 AM
Clean install karmic server amd64, then do-release-upgrade to lucid worked for me eventually.