PDA

View Full Version : [ubuntu] 10.04 Noob - NVidea accelerated .mkv video ?



Torricumbo
April 30th, 2010, 11:06 PM
Hi,

Total Linux & Ubuntu noob here :-) Have setup my Dell Dimension 9200 Tower (Pentium 4, 3.2Ghz, 3GB RAM, Nvidea GEForce 9600) with Lucid 32 bit.

I'd like to be able to play my 1080p mkv (.264) video library on my Ubuntu system that I use as a media centre.

What is the easiest method to get GPU accelerated video playback for above please ?

I have tried the built-in Movie Player, Boxee (which I use for other videos anyway) and VLC - all of which play but with a small amount of stutter - enough to be annoying. As far as I can tell these apps do not use NVidea GPU acceleration. In all cases I have used the defaults provided either by Ubuntu/Boxee/VLC.

Is MPlayer the answer ?

BTW I'm a relatively "non-tech-enthusiast" coming from the Microsoft environment. I'm comfortable with DOS command line but have never used Linux command line, so please be gentle with me :-)

Thanks,

Torricumbo

fh_scott
May 1st, 2010, 12:14 AM
Start here:

http://ubuntuforums.org/showthread.php?t=1037625

"These instructions are not basic enough for a total newbie."

In a nutshell, you need to add a new PPA (where Symantec and Apt download software from). The new PPA will have versions of Mplayer that have been compiled for vdpau support (hardware accelerated x264 decoding).

After you get the PPA setup you want to install mplayer-nogui and smplayer (sudo apt-get install mplayer-nogui smplayer)

Then launch smplayer, go to the Video preferences and change the output driver to vdpau.

See how far you can get with that.

-sdf

themusicalduck
May 1st, 2010, 03:03 AM
Actually the Mplayer that is in the Ubuntu repos has vdpau support already. I use it with SMplayer.

So I'd recommend getting SMplayer from the Software Centre and then change the output to vdpau in preferences.

Torricumbo
May 1st, 2010, 01:05 PM
Actually the Mplayer that is in the Ubuntu repos has vdpau support already. I use it with SMplayer.

So I'd recommend getting SMplayer from the Software Centre and then change the output to vdpau in preferences.

Oooh thanks - I'll give that a try when I get home tonight. I was worried about being stuck as the first reply to this post was going to be waaay beyond by Ubuntu competence levels.

I'll post back here with how I get on.

Torricumbo

Torricumbo
May 3rd, 2010, 08:10 AM
Actually the Mplayer that is in the Ubuntu repos has vdpau support already. I use it with SMplayer.

So I'd recommend getting SMplayer from the Software Centre and then change the output to vdpau in preferences.

When I select vdpau in SMplayer preferences I get an error when trying to play video saying

Mplayer has finished unexpectedly: Exit Code 1

If I reset the preference back to default (xv) then it plays but very stuttered, not using the gpu.

I checked to see that the following is already installed with the OS: "Nvidea binary Xorg driver, kernel module and vdpau library - 185"

Am I doing something wrong do you think ?

Torricumbo
May 3rd, 2010, 08:43 AM
Here's the content of the SMPlayer log file that accompanies the above error

/usr/bin/mplayer -noquiet -nofs -nomouseinput -vc ffh264vdpau,ffmpeg12vdpau,ffwmv3vdpau,ffvc1vdpau, -sub-fuzziness 1 -identify -msglevel demux=6 -slave -vo vdpau -ao alsa -nokeepaspect -framedrop -nodr -double -input conf=/usr/share/smplayer/input.conf -stop-xscreensaver -wid 75497809 -monitorpixelaspect 1 -*** -embeddedfonts -***-line-spacing 0 -***-font-scale 1 -***-styles /home/tbird1/.config/smplayer/styles.*** -fontconfig -font Arial -subfont-autoscale 0 -subfont-osd-scale 20 -subfont-text-scale 20 -subcp ISO-8859-1 -vid 0 -aid 0 -subpos 100 -cache 2000 -osdlevel -vf-add screenshot -vf-clr -slices -channels 2 -af equalizer=0:0:0:0:0:0:0:0:0:0 -softvol -softvol-max 110 /home/tbird1/Desktop/Island.2009.1080p.BluRay.DTS.x264-ESiR.mkv

bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
MPlayer SVN-r1.0~rc3+svn20090426-4.4.3 (C) 2000-2009 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.
Terminal type `unknown' is not defined.

Playing /home/tbird1/Desktop/Island.2009.1080p.BluRay.DTS.x264-ESiR.mkv.

Cache fill: 0.00% (0 bytes)
Checking for YUV4MPEG2
Checking for REAL
Checking for SMJPEG
[mkv] Found the head...
[mkv] + a segment...
[mkv] /---- [ parsing seek head ] ---------
[mkv] /---- [ parsing seek head ] ---------
[mkv] \---- [ parsing seek head ] ---------
[mkv] /---- [ parsing cues ] -----------
[mkv] \---- [ parsing cues ] -----------
[mkv] \---- [ parsing seek head ] ---------
[mkv] |+ segment information...
[mkv] | + timecode scale: 1000000
[mkv] | + duration: 9701.686s
[mkv] |+ segment tracks...
[mkv] | + a track...
[mkv] | + Track number: 1
[mkv] | + Track type: Video
[mkv] | + Default flag: 1
[mkv] | + Codec ID: V_MPEG4/ISO/AVC
[mkv] | + CodecPrivate, length 42
[mkv] | + Default duration: 41.708ms ( = 23.976 fps)
[mkv] | + Language: eng
[mkv] | + Video track
[mkv] | + Pixel width: 1920
[mkv] | + Pixel height: 1080
[mkv] | + Display width: 16
[mkv] | + Display height: 9
[mkv] | + a track...
[mkv] | + Track number: 2
[mkv] | + Track type: Audio
[mkv] | + Default flag: 1
[mkv] | + Codec ID: A_DTS
[mkv] | + Language: eng
[mkv] | + Audio track
[mkv] | + Sampling frequency: 48000.000000
[mkv] | + Channels: 6
[mkv] | + a track...
[mkv] | + Track number: 3
[mkv] | + Track type: Subtitle
[mkv] | + Default flag: 1
[mkv] | + Codec ID: S_TEXT/***
[mkv] | + CodecPrivate, length 890
[mkv] | + Language: eng
[mkv] | + a track...
[mkv] | + Track number: 4
[mkv] | + Track type: Subtitle
[mkv] | + Default flag: 0
[mkv] | + Codec ID: S_TEXT/***
[mkv] | + CodecPrivate, length 785
[mkv] | + Language: eng
[mkv] | + Name: Foreign parts
[mkv] | + a track...
[mkv] | + Track number: 5
[mkv] | + Track type: Subtitle
[mkv] | + Default flag: 0
[mkv] | + Codec ID: S_TEXT/***
[mkv] | + CodecPrivate, length 772
[mkv] | + Language: hrv
[mkv] | + a track...
[mkv] | + Track number: 6
[mkv] | + Track type: Subtitle
[mkv] | + Default flag: 0
[mkv] | + Codec ID: S_TEXT/***
[mkv] | + CodecPrivate, length 772
[mkv] | + Language: dan
[mkv] | + a track...
[mkv] | + Track number: 7
[mkv] | + Track type: Subtitle
[mkv] | + Default flag: 0
[mkv] | + Codec ID: S_TEXT/***
[mkv] | + CodecPrivate, length 772
[mkv] | + Language: dut
[mkv] | + a track...
[mkv] | + Track number: 8
[mkv] | + Track type: Subtitle
[mkv] | + Default flag: 0
[mkv] | + Codec ID: S_TEXT/***
[mkv] | + CodecPrivate, length 774
[mkv] | + Language: fin
[mkv] | + a track...
[mkv] | + Track number: 9
[mkv] | + Track type: Subtitle
[mkv] | + Default flag: 0
[mkv] | + Codec ID: S_TEXT/***
[mkv] | + CodecPrivate, length 772
[mkv] | + Language: fre
[mkv] | + a track...
[mkv] | + Track number: 10
[mkv] | + Track type: Subtitle
[mkv] | + Default flag: 0
[mkv] | + Codec ID: S_TEXT/***
[mkv] | + CodecPrivate, length 772
[mkv] | + Language: ger
[mkv] | + a track...
[mkv] | + Track number: 11
[mkv] | + Track type: Subtitle
[mkv] | + Default flag: 0
[mkv] | + Codec ID: S_TEXT/***
[mkv] | + CodecPrivate, length 772
[mkv] | + Language: hun
[mkv] | + a track...
[mkv] | + Track number: 12
[mkv] | + Track type: Subtitle
[mkv] | + Default flag: 0
[mkv] | + Codec ID: S_TEXT/***
[mkv] | + CodecPrivate, length 772
[mkv] | + Language: ita
[mkv] | + a track...
[mkv] | + Track number: 13
[mkv] | + Track type: Subtitle
[mkv] | + Default flag: 0
[mkv] | + Codec ID: S_TEXT/***
[mkv] | + CodecPrivate, length 772
[mkv] | + Language: nor
[mkv] | + a track...
[mkv] | + Track number: 14
[mkv] | + Track type: Subtitle
[mkv] | + Default flag: 0
[mkv] | + Codec ID: S_TEXT/***
[mkv] | + CodecPrivate, length 772
[mkv] | + Language: pol
[mkv] | + a track...
[mkv] | + Track number: 15
[mkv] | + Track type: Subtitle
[mkv] | + Default flag: 0
[mkv] | + Codec ID: S_TEXT/***
[mkv] | + CodecPrivate, length 772
[mkv] | + Language: por
[mkv] | + a track...
[mkv] | + Track number: 16
[mkv] | + Track type: Subtitle
[mkv] | + Default flag: 0
[mkv] | + Codec ID: S_TEXT/***
[mkv] | + CodecPrivate, length 772
[mkv] | + Language: rum
[mkv] | + a track...
[mkv] | + Track number: 17
[mkv] | + Track type: Subtitle
[mkv] | + Default flag: 0
[mkv] | + Codec ID: S_TEXT/***
[mkv] | + CodecPrivate, length 772
[mkv] | + Language: scc
[mkv] | + a track...
[mkv] | + Track number: 18
[mkv] | + Track type: Subtitle
[mkv] | + Default flag: 0
[mkv] | + Codec ID: S_TEXT/***
[mkv] | + CodecPrivate, length 772
[mkv] | + Language: swe
[mkv] | + a track...
[mkv] | + Track number: 19
[mkv] | + Track type: Subtitle
[mkv] | + Default flag: 0
[mkv] | + Codec ID: S_TEXT/***
[mkv] | + CodecPrivate, length 774
[mkv] | + Language: tur
[mkv] /---- [ parsing attachments ] ---------
[mkv] | + an attachment...
[mkv] | + FileName: arial.ttf
[mkv] | + FileMimeType: application/x-truetype-font
[mkv] | + FileData, length 367112
[mkv] Attachment: arial.ttf, application/x-truetype-font, 367112 bytes
[mkv] | + an attachment...
[mkv] | + FileName: PapyrusStd.otf
[mkv] | + FileMimeType: application/x-truetype-font
[mkv] | + FileData, length 111376
[mkv] Attachment: PapyrusStd.otf, application/x-truetype-font, 111376 bytes
[mkv] \---- [ parsing attachments ] ---------
[mkv] |+ found cluster, headers are parsed completely :)
ID_VIDEO_ID=0
[mkv] Aspect: 1.777778
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
ID_AUDIO_ID=0
ID_AID_0_LANG=eng
[mkv] Track ID 2: audio (A_DTS), -aid 0, -alang eng
ID_SUBTITLE_ID=0
ID_SID_0_LANG=eng
[mkv] Track ID 3: subtitles (S_TEXT/***), -sid 0, -slang eng
ID_SUBTITLE_ID=1
ID_SID_1_NAME=Foreign parts
ID_SID_1_LANG=eng
[mkv] Track ID 4: subtitles (S_TEXT/***) "Foreign parts", -sid 1, -slang eng
ID_SUBTITLE_ID=2
ID_SID_2_LANG=hrv
[mkv] Track ID 5: subtitles (S_TEXT/***), -sid 2, -slang hrv
ID_SUBTITLE_ID=3
ID_SID_3_LANG=dan
[mkv] Track ID 6: subtitles (S_TEXT/***), -sid 3, -slang dan
ID_SUBTITLE_ID=4
ID_SID_4_LANG=dut
[mkv] Track ID 7: subtitles (S_TEXT/***), -sid 4, -slang dut
ID_SUBTITLE_ID=5
ID_SID_5_LANG=fin
[mkv] Track ID 8: subtitles (S_TEXT/***), -sid 5, -slang fin
ID_SUBTITLE_ID=6
ID_SID_6_LANG=fre
[mkv] Track ID 9: subtitles (S_TEXT/***), -sid 6, -slang fre
ID_SUBTITLE_ID=7
ID_SID_7_LANG=ger
[mkv] Track ID 10: subtitles (S_TEXT/***), -sid 7, -slang ger
ID_SUBTITLE_ID=8
ID_SID_8_LANG=hun
[mkv] Track ID 11: subtitles (S_TEXT/***), -sid 8, -slang hun
ID_SUBTITLE_ID=9
ID_SID_9_LANG=ita
[mkv] Track ID 12: subtitles (S_TEXT/***), -sid 9, -slang ita
ID_SUBTITLE_ID=10
ID_SID_10_LANG=nor
[mkv] Track ID 13: subtitles (S_TEXT/***), -sid 10, -slang nor
ID_SUBTITLE_ID=11
ID_SID_11_LANG=pol
[mkv] Track ID 14: subtitles (S_TEXT/***), -sid 11, -slang pol
ID_SUBTITLE_ID=12
ID_SID_12_LANG=por
[mkv] Track ID 15: subtitles (S_TEXT/***), -sid 12, -slang por
ID_SUBTITLE_ID=13
ID_SID_13_LANG=rum
[mkv] Track ID 16: subtitles (S_TEXT/***), -sid 13, -slang rum
ID_SUBTITLE_ID=14
ID_SID_14_LANG=scc
[mkv] Track ID 17: subtitles (S_TEXT/***), -sid 14, -slang scc
ID_SUBTITLE_ID=15
ID_SID_15_LANG=swe
[mkv] Track ID 18: subtitles (S_TEXT/***), -sid 15, -slang swe
ID_SUBTITLE_ID=16
ID_SID_16_LANG=tur
[mkv] Track ID 19: subtitles (S_TEXT/***), -sid 16, -slang tur
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO: [avc1] 1920x1080 24bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
ID_FILENAME=/home/tbird1/Desktop/Island.2009.1080p.BluRay.DTS.x264-ESiR.mkv
ID_DEMUXER=mkv
ID_VIDEO_FORMAT=avc1
ID_VIDEO_BITRATE=0
ID_VIDEO_WIDTH=1920
ID_VIDEO_HEIGHT=1080
ID_VIDEO_FPS=23.976
ID_VIDEO_ASPECT=1.7778
ID_AUDIO_FORMAT=8193
ID_AUDIO_BITRATE=0
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=6
ID_LENGTH=9701.69
ID_SEEKABLE=1
ID_CHAPTERS=0
[vdpau] Could not open dynamic library libvdpau.so.1
Error opening/initializing the selected video_out (-vo) device.
================================================== ========================
Opening audio decoder: [libdca] DTS decoding with libdca
Stream with high frequencies VQ coding
AUDIO: 48000 Hz, 2 ch, s16le, 1536.0 kbit/100.00% (ratio: 192000->192000)
ID_AUDIO_BITRATE=1536000
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=2
Selected audio codec: [dts] afm: libdca (DTS-libdca)
================================================== ========================
AO: [alsa] 48000Hz 2ch floatle (4 bytes per sample)
ID_AUDIO_CODEC=dts
Video: no video
Starting playback...
[Mixer] No hardware mixing, inserting volume filter.


MPlayer interrupted by signal 11 in module: key_events
ID_SIGNAL=11
- MPlayer crashed by bad usage of CPU/FPU/RAM.
Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
gcc version. If you think it's MPlayer's fault, please read
DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
won't help unless you provide this information when reporting a possible bug.
[ This binary of MPlayer in Debian is currently compiled with
'--enable-debug'; the debugging symbols are in the package
'mplayer-dbg'.]

Jive Turkey
May 3rd, 2010, 09:02 AM
It might help if you open smplayer in a terminal (from the command line) and repeat the steps above. It will likely give more info as to the cause of the crash. Copy the messages into a post here.

Also, before you change the setting to vdpau, open options > view logs > mplayer log. There might be some clues there. Mine looks like this
/usr/bin/mplayer -noquiet -nofs -nomouseinput -vc ffh264vdpau,ffmpeg12vdpau,ffwmv3vdpau,ffvc1vdpau, -sub-fuzziness 1 -identify -slave -vo vdpau -ao oss -nokeepaspect -framedrop -nodr -double -input nodefault-bindings:conf=/dev/null -stop-xscreensaver -wid 83886423 -monitorpixelaspect 1 -*** -embeddedfonts -***-line-spacing 0 -***-font-scale 1 -***-styles /home/crk/.config/smplayer/styles.*** -fontconfig -font Arial -subfont-autoscale 0 -subfont-osd-scale 20 -subfont-text-scale 20 -subcp ISO-8859-1 -vid 0 -subpos 100 -volume 100 -cache 2000 -osdlevel 0 -slices -channels 2 -af scaletempo,equalizer=0:0:0:0:0:0:0:0:0:0 -softvol -softvol-max 110 /home/crk/Videos/Moon(2009).mkv

MPlayer SVN-r31042-Ubuntu-RVM (C) 2000-2010 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.


Cache fill: 0.00% (0 bytes)
ID_VIDEO_ID=0
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
ID_AUDIO_ID=0
ID_AID_0_LANG=und
[mkv] Track ID 2: audio (A_DTS), -aid 0, -alang und
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO: [avc1] 1024x426 24bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
ID_FILENAME=*****
ID_DEMUXER=mkv
ID_VIDEO_FORMAT=avc1
ID_VIDEO_BITRATE=0
ID_VIDEO_WIDTH=1024
ID_VIDEO_HEIGHT=426
ID_VIDEO_FPS=23.976
ID_VIDEO_ASPECT=2.4038
ID_AUDIO_FORMAT=8193
ID_AUDIO_BITRATE=0
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=6
ID_LENGTH=5829.80
ID_SEEKABLE=1
ID_CHAPTERS=0
Couldn't open video filter '***'.
***: cannot add video filter
[***] Init
[***] Updating font cache
================================================== ========================
Forced video codec: ffh264vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))
================================================== ========================
ID_VIDEO_CODEC=ffh264vdpau
================================================== ========================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, s16le, 768.0 kbit/50.00% (ratio: 96000->192000)
ID_AUDIO_BITRATE=768000
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=2
Selected audio codec: [ffdca] afm: ffmpeg (FFmpeg DTS)
================================================== ========================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
ID_AUDIO_CODEC=ffdca
[Mixer] No hardware mixing, inserting volume filter.
Starting playback...
[VD_FFMPEG] Trying pixfmt=0.
Movie-Aspect is 2.40:1 - prescaling to correct movie aspect.
ID_VIDEO_ASPECT=2.4038
VO: [vdpau] 1024x426 => 1024x426 H.264 VDPAU acceleration
[VD_FFMPEG] XVMC-accelerated MPEG-2.

Jive Turkey
May 3rd, 2010, 09:19 AM
Ah, you beat me to it. You could try what it says and make a gdb backtrace after installing mplayer-dbg. There is a similar thread to this one, http://newyork.ubuntuforums.org/showthread.php?p=9215216

that was solved when the user installed libvdpau1
sudo apt-get install libvdpau1

Torricumbo
May 3rd, 2010, 09:28 AM
Ah, you beat me to it. You could try what it says and make a gdb backtrace after installing mplayer-dbg. There is a similar thread to this one, http://newyork.ubuntuforums.org/showthread.php?p=9215216

that was solved when the user installed libvdpau1
sudo apt-get install libvdpau1


Would I need to un-install anything before trying that do you think ?

Jive Turkey
May 3rd, 2010, 09:38 AM
I don't think so but apt will tell you and offer you yes or no or tell you if there is a conflict.