PDA

View Full Version : [ubuntu] Skip Compiz Checks in Lucid Lynx



goober99
April 30th, 2010, 09:17 PM
Just upgraded from 9.10 to 10.04. When I tried to enable desktop effects from the Appearance Preferences, got "Desktop effects cannot be enabled."

No problem. Same thing happened on 9.10. I just ran the compiz-check script and told it to skip blacklist checks. Then everything worked fine.

I did the same thing on my freshly installed 10.04. Then tried enabling desktop effects. Still could not be enabled.

It seems the compiz-check script is unable to disable the blacklist checks in 10.04, because I typed "compiz" into a terminal and got this:


Blacklisted PCI ID 8086:2562 detected

Before you say, maybe Compiz just doesn't work with your video card: I installed fusion-icon, selected Compiz as my Window Manager, and Compiz started up fine. I just don't want the extra step of selecting Compiz from fusion-icon every time I reboot. I want Compiz to be enabled automatically when I boot up.

Does anyone know how to skip the blacklist checks in 10.04?

jimbudler
April 30th, 2010, 11:46 PM
I had the same problem including being able to start it from fuzion-icon, and with some troubleshooting found:

/etc/xdg/compiz/compiz-manager contained:

COMPIZ_NAME="compiz.real"
which no longer existed. I changed to:

COMPIZ_NAME="compiz"

compiz started up automatically on my next login.

Don1500
May 1st, 2010, 12:24 AM
Since we're talking about 10.04 and Compiz...

Has some of Compiz's functionality been removed? No deformed cube, no 3-d windows, No Flaming windows. Just wondering.

Opps, Never mind. Forgot to load the extras!

goober99
May 1st, 2010, 12:51 AM
The file /etc/xdg/compiz/compiz-manager does not exist on my computer. I created it with the contents


COMPIZ_NAME="compiz"
SKIP_CHECKS="yes"

and I can still only launch Compiz from fusion-icon.

auh2o
May 1st, 2010, 05:09 PM
I had the same problem including being able to start it from fuzion-icon, and with some troubleshooting found:

/etc/xdg/compiz/compiz-manager contained:

COMPIZ_NAME="compiz.real"
which no longer existed. I changed to:

COMPIZ_NAME="compiz"

compiz started up automatically on my next login.

That didn't work for me, even though I have said file. How does the rest of yours look? Mine as follows (after applying your edit):


COMPIZ_BIN_PATH="/usr/bin/"
PLUGIN_PATH="/usr/lib/compiz/"
COMPIZ_NAME="compiz"

konlungkao
May 1st, 2010, 05:22 PM
That didn't work for me too

kage52124
May 1st, 2010, 07:31 PM
Same problem here, earlier edit from compiz.real to compiz didn't work, nor has SKIP CHECKS=yes.

This is strange because Compiz worked fine in 9.04 and 9.10. I don't understand why it would be blacklisted now...

zpletan
May 2nd, 2010, 12:48 AM
sudo apt-get install ghex
sudo ghex2 /usr/bin/compiz

Now search for the ASCII string "8086:2562" (minus quotes, of course), and change it slightly - I changed the 2 to a 3.

I have the same graphics card (8086:2562) built into... something I can't take out (don't quite remember what), but I also have a PCI NVIDIA card that I actually use, so the fact that the Intel card keeps me from using Compiz is quite annoying.

Now that I've fixed this and gotten a fatal error, I'm off to replace nouveau with NVIDIA (goodbye KMS :(), and try again.

zpletan
May 2nd, 2010, 02:45 AM
I can now confirm that my solution works (for me). You may need to install some proprietary drivers if compiz won't work with your video card out-of-the-box.

Now I just have to decide how much I love my wobbly windows - nouveau made my system seem much snappier.

goober99
May 2nd, 2010, 04:54 AM
Me too, zpletan. I'm actually using a NVIDIA GeForce 8400GS video card, which Compiz works find with, but Ubuntu still sees the integrated Intel video card I can't remove even though I don't use it.

goober99
May 2nd, 2010, 05:05 AM
Your trick worked for me too, zpletan. You're amazing! Thanks!

oyok2112
May 19th, 2010, 07:32 AM
Exactly what I have spent a week looking for! (Still was a bit simpler running SKIP_CHECK=yes...but I'll take it!)

revnobody
June 1st, 2010, 11:00 PM
I was wondering if this will work if I only have the intel chipset. I am a complete NOOB, I am really excited about trying compiz, but so far I am disappointed that I can't get it to work.

zpletan
June 2nd, 2010, 12:23 AM
I was wondering if this will work if I only have the intel chipset. I am a complete NOOB, I am really excited about trying compiz, but so far I am disappointed that I can't get it to work.
You can try, but last time I tried this with the Intel chipset (on Karmic), it didn't work, and I don't have much reason to think that it will now. If you want to try, make sure to backup /usr/bin/compiz before you go in and change it, and shut down all your programs before you test in case you have to manually power-off. (You might also want to make sure that you know how to restore the compiz binary via the command-line in recovery mode in case something gets borked real good.)

revnobody
June 2nd, 2010, 01:50 AM
Thank you. I took your advice and tried it....but it didn't work. Oh well guess I will live with it for now. Thanks for all the help.

andrewkk
June 27th, 2010, 01:37 AM
sudo apt-get install ghex
sudo ghex2 /usr/bin/compiz

Now search for the ASCII string "8086:2562" (minus quotes, of course), and change it slightly - I changed the 2 to a 3.

As soon as an update to Compiz comes through this hack will be overwritten. This is not a resolution to the problem.

zpletan
June 28th, 2010, 12:18 AM
As soon as an update to Compiz comes through this hack will be overwritten. This is not a resolution to the problem.

You are exactly right - plan accordingly if you follow this workaround. However, I don't have a patch to permanently fix this, and a workaround is better than nothing.

There is a bug for this at https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/297234

andrewkk
June 28th, 2010, 04:53 PM
Glad to see the bug report. Thanks!

CoreyB.
July 21st, 2010, 05:45 AM
Thanks for the workaround zpletan! I have a Nvidia GeForce 8400 GS 512MB PCI card, but my integrated intel gpu makes it so I can't enable compiz, but your workaround helped. I hope we get a fix soon!

jwboyer
January 9th, 2011, 11:34 PM
The hex edit worked for me.

I have a geoforce 9500 and had not been able to use the Compiz graphics. Noveau is Blacklisted and NVIDIA 260 .19.29 is installed with NVIDIA loader. Strangely, the no drivers appear under Hardware Drivers.

glenn69
March 3rd, 2011, 07:59 PM
This worked for me also. Any word on a permanent fix to this?

sk4tec
May 17th, 2011, 04:51 PM
having this exact issue but when trying to find the "8086:2562" string in the compiz "exe" nothing comes back so I can't change it.

On another note if the system is running slow (its only 2.4 Ghz Celeron with 1.25 GB RAM and this 'new' gfx Fx5200 card) is compiz going to slow it down further??

CoreyB.
July 15th, 2011, 05:23 PM
The equivalent of this fix for 11.04 is as follows:

Start gedit using sudo by opening Terminal and executing "sudo gedit" and then typing your password.

Then in gedit, open "/etc/environment".

At the end of the file add "UNITY_FORCE_START=1" on its own line.

Then save the file and reboot your computer and make sure "Ubuntu" is selected in GDM as the desktop environment when you log back in.