PDA

View Full Version : [ubuntu] No Sound On Install



yarnoiser
April 30th, 2010, 06:45 PM
Just upgraded from Ubuntu 9.10 to 10.04. After upgrading, the sound had been lost, there were no sounds of any kind. After that, I did a fresh install, still no sound. I'm not sure what sound card I have, or how to find out. There's also a lingering issue from 9.10 that carried over: in some, but not all games, there is constant mouse and keyboard directional input. I don't touch anything and the player will move. Does anyone know how to fix either problem?

pauljwells
April 30th, 2010, 07:02 PM
Have you tried alsa-mixer? On my Audigy sound card I have to run alsa-mixer, tab along to 'Audigy Analog/Digital Output Jack' and press M (or space, not sure) to un-mute it. Have something playing so that you can hear immediately if you pressed the right thing!

avrono
April 30th, 2010, 07:06 PM
I am having the same problem, in upgrading from 9.04 to 10.04, I no longer have sound. I am sure something is muted. It turns out that it was the ASLA mixer, any ideas how to get the volume control back onto the toolbar ?

eigenadam
April 30th, 2010, 07:10 PM
Run gnome-volume-control-applet from a terminal and that will get it back.

Supposedly volume is on the indicator applet now, but it is missing from mine.

I had to run alsaconf to get my sound to work, but it's not working well. No sound in firefox, and the mic does not work.

doktorOblivion
April 30th, 2010, 08:16 PM
I had to install pavucontrol (pulse audio) volume control, before it would work.

yarnoiser
April 30th, 2010, 11:44 PM
Okay, don't try OSS. That got sound working so that if you go into a room where you can hear a pin drop and set the volume to maximum you can hear the audio very faintly. I'm switching back to ALSA.

yarnoiser
May 1st, 2010, 07:24 PM
Okay, I've solved my audio problem, so anyone having similar problems can follow these directions: first, I'm using an intel HDA sound card and the above posted methods did not work. First, switch to OSS, despite what I posted above, there is a way to boost volume. Use the instructions at this url to install OSS.

https://help.ubuntu.com/community/OpenSound

Next, there will be a mention at the above link to a ppa for gnome volume control. This will enable you to adjust volume in OSS without using the terminal. The ppa is at the following url.

https://launchpad.net/~dtl131/+archive/ppa

Follow the instructions for adding this location to your software sources. Then go to your menu bar: System, Administration, Synaptic Package Manager. Press the "Mark All Upgrades" button and hit apply. This will remove "Sound" from your preferences menu, but it doesn't work with OSS anyway. Then, right click on one of your panels and hit "add to panel". Choose "volume control" from the menu, this volume control will not appear in any menus, that threw me off the first time I tried this. Select preferences in volume control, try the switches and options one by one, one of them should do something if your getting even minimal audio, just keep looking until you find it.

OSS for the WIN!!!