View Full Version : [SOLVED] Terminal can't execute binairy files.

April 30th, 2010, 05:58 PM

I've searched around for similar problems but I couldn't a usefull post.
I just installed Ubuntu 10.xx and I'm new. I want to install Savage2 with the terminal.
So I downloaded a binairy file and and I tried to execute it, but the terminal gave me this error:

orangetux@orangetux-laptop:~/Downloads$ chmod 755 ./Savage2Install-2.1.0-x86_64.bin
orangetux@orangetux-laptop:~/Downloads$ ./Savage2Install-2.1.0-x86_64.bin
bash: ./Savage2Install-2.1.0-x86_64.bin: can't execute binairy file

What's the problem?

May 1st, 2010, 06:27 PM
Hello and welcome to Ubuntuforums.

First of all, is your system 32bit or 64bit?

You can find this out via typing (or copy and paste) into the terminal:

uname -m


May 1st, 2010, 09:22 PM
FYI, it looks like you downloaded the wrong Savage Installer file. You most likely have a 32 bit system, so you need the 32 bit installer, what you are trying to run is the 64 bit installer, which is incompatible with 32 bit system, hence your system cannot execute the file.


May 2nd, 2010, 02:31 PM
Yes, I've a 32 bit system. Thanks. Now, I'm downloading a 32 bit version. Hope that it works

May 3rd, 2010, 11:25 AM
Thanks a lot, it worked!